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1 License Terms

It is strictly prohibited to reproduce the program or the accompanying written material, in whole
or in part, in its original or modified form.

All our data carriers are thoroughly checked for viruses and errors before shipping. BOENIGK-
electronics assumes no liability for any damages that may result from the operation of our
programs (including, but not limited to, data loss, machine damage, material damage, personal
injury, additional expenses, or incorrect results).
Under no circumstances shall BOENIGK-electronics be held liable to the licensee or third
parties for compensation of any damages or consequential damages, such as fines or penalties,
nor for compensation claims arising from loss of profits, business interruptions, loss of business
information, or other financial losses caused by the use or attempted use of the software and
hardware.

The electronic license registration must not be removed or modified. All copies must exactly
match the original supplied version.

Microsoft, Windows, Autodesk, AutoCAD, Adobe, Hewlett-Packard, and other product and
company names mentioned in this book are registered trademarks of their respective owners.
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2 Basics

The cncGraF 8 software controls CNC machines with up to six axes.

Control is handled via the smc5d controller. Among other tasks, this controller performs timer
functions and outputs step and direction signals to drive up to seven stepper/servo motors (up to
six axes plus a dual drive for X/Y). Its inputs and outputs can control various external devices
such as spindles, pumps, and pneumatic systems. Inputs are used for home/reference switches,
emergency stop switches, and other automation tasks.

Several controller variants are available, ranging from the entry-level smc5d-p32 to an industrial
network version for control cabinets. For more information, please visit our website at
cncgraf.com.

cncGraF 8 is available in two editions. cncGraF 8Standard is an affordable alternative to the
higher-end cncGraF 8 Professional. You can upgrade from Standard to Professional at any time.
To see a tabular comparison of the editions, open the main menu and choose Help →
Differences Between Versions.

About this manual
The cncGraF 8 software offers many settings and advanced features. During development we
made every effort, with great care, to provide our customers with the broadest possible range of
functionality. In some cases, this documentation may not cover every function or detail. If you
have suggestions for improving this documentation, please email us at info@boenigk-
electronics.com. Thank you!

Text marked with the warning symbol  indicates potential hazards. The info symbol 
highlights important information.

 This documentation has been automatically translated. It may contain errors or
inaccuracies. The official version is the original German text.
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2.1 What Can cncGraF 8 Do?

cncGraF 8 features a modern, clear, and intuitive graphical user interface, where all important
functions can be accessed either via icons or keyboard shortcuts. The CAD-like interface
represents the machine workspace. Within this area, elements such as drawing data, the
workpiece, the zero point, parking positions, or measuring positions are displayed.

Typical applications of cncGraF 8 include:
· Milling
· Drilling
· Cutting foils
· Engraving
· Probing
· Plotting
· Digitizing
· Automation
· Laser cutting
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2.2 What’s New?

The new cncGraF 8 software comes with many additional features. This page provides a quick
overview:

· Optimized user interface for more intuitive operation

· 3D probe for higher precision and productivity

· Multiple measurement routines for improved accuracy

· Customizable “Manual Move” dialog

· Spindle warm-up: extend the lifetime of your spindle

· Extended G-code functionality: IF statements and R parameters for greater flexibility

· Tool palette: simple editing of DXF files

· Angle head support for bevel or inclined cuts

· Laser cutting

· Control of up to six axes

2.3 What Else Do You Need?

In addition to the cncGraF 8 software, you will need the following hardware and software
components:

· Operating system: Microsoft Windows 10/11 (64-bit version)

· Microsoft .NET Framework v4.8

· Processor: Intel i3 or higher

· Graphics card with OpenGL support

· RAM: 8 GB

· Hard disk space: 500 MB free

· Controller: smc5d or smc5d-m4

cncGraF 8 is built on Microsoft .NET technology and requires Microsoft .NET Framework
v4.8. The .NET Framework is available free of charge and can be downloaded from the official
Microsoft website.
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2.4 Installation

 Please read this page carefully before starting the installation!

Installing cncGraF 8

1. Run the cncgraf8.setup.exe file to install cncGraF 8. The cncGraF 8 installer will guide you
step by step through the installation process.

The cncGraF 8 control requires the smc5d controller.

Installing the smc5d USB Driver 

The USB driver can be installed automatically. To do this, select Install USB driver in the setup
wizard at the end of the cncGraF 8 installation. Then follow the on-screen instructions.

Manual driver installation

Connect the controller to your PC with a USB cable. Windows will then attempt to locate the
appropriate driver automatically.

If Windows cannot find the driver automatically
Open the Windows Device Manager (Start > Control Panel > Device Manager). The smc5d
controller will appear under Other Devices as not installed.

Right-click on the controller entry smc5d-p32 and select Update Driver Software.... A dialog
will open with the title How do you want to search for driver software? Choose Browse my
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computer for driver software. You can then select the folder where the driver is located. The
driver is included in the cncGraF 8 installation directory under ...\driver. Click Next to continue.

The driver installation will now proceed and complete.
Once installed, the smc5d driver will appear in Device Manager under the name smc5d-p32w
controller. The smc5d controller is now ready for use.
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2.5 Starting cncGraF 8

You can start cncGraF 8 either by clicking the desktop icon or through the Start menu. Running
multiple instances of cncGraF 8 is only possible when using multiple controllers. At startup, a file
name and directory can also be passed as command-line parameters. Example: cncp7.exe c:
\directory\file.plt

"Welcome" Window
When the program is launched for the first time, the Welcome window appears.

This window informs the user that no machine settings are currently available, which are required
for the proper operation of the CNC control.
The machine file (system backup file with the extension .SBF) can already be specified in this
window. Alternatively, the settings can be restored later via the menu Settings → System
Settings → Restore. For more details, see the section Basics → Settings.

 A detailed description of all machine parameters is provided in the chapter Machine
Parameters.
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2.6 License

If no license is available, a license notification will appear in the upper-right corner of the main
window.

The license includes a 30-day trial period. After this period, it can be extended or unlocked with
a license key. Activation is also possible before the trial period expires.

To activate the smc5d or smc5d-m4 controller, you will need a license file from your machine
manufacturer.

Once you have received the license key, proceed as follows:

1. Open cncGraF 8
2. Left-click on the message in the upper-right corner: "The license will expire in x days!
Please enter the license file here."
3. Select the corresponding license file with the .lic extension and click Open.

The controller is now activated.

 Since the license is stored directly on the controller, it does not need to be re-entered if you
change PCs or reinstall the software.
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2.7 Upgrade to cncGraF 8 Pro

cncGraF 8 is available in two editions. An upgrade from Standard to Professional can be
performed at any time. The following steps are required to complete the upgrade:
1. To upgrade, you will need cncGraF 8 Standard as well as the upgrade file cnc_xx-xxxx-

xxxxxxx.upgrade. The name of the upgrade file corresponds to the controller’s serial number
(example: a controller with serial number 15-1215-4466070 uses the upgrade file cnc_15-
1215-4466070.upgrade). 
The smc5d controller must be connected to the PC in order to perform the upgrade.

2. The upgrade is initiated via the main menu command Help → Upgrade to cncGraF 8 Pro...
3. If the menu item Upgrade to cncGraF 8 Pro... is not available,cncGraF 8 Pro is already

running. In that case, switch to cncGraF 8 Standard by selecting Help → Version
Selection.

4. Clicking Upgrade to cncGraF 8 Pro... opens the Sof tware Upgrade dialog. In the File
field, you must specify the upgrade file. To do this, click the button to browse for the upgrade
file.

5. Click the Start button  to begin the upgrade process.

 Warning: During the upgrade process, neither the controller nor the PC must be
disconnected from power!

Once the upgrade is complete, switch to the cncGraF 8 Professional edition by selecting Help
→ Version Selection. The upgrade is now finished. The upgrade file is no longer required and
may be deleted.

2.8 Settings

Due to its complexity, cncGraF 8 offers a wide range of program settings and machine
parameters. All these settings are centrally stored in the file conf ig.xml. Tool settings are stored
in the files vectors.xml and drilltools.xml. All configuration files are located in the directory ...
\Users\[BENUTZERNAME] \AppData\Roaming\cncGraF8\.

Backing up settings

 Important: o prevent data loss, it is strongly recommended to back up your settings
regularly to an external storage device. All settings can be saved via the menu Settings →
System Settings → Backup...
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Restoring settings
Saved settings can be restored from the menu Settings → System Settings → Restore...

2.9 User Interface Layout

cncGraF 8 provides a user interface and menu structure largely based on standard Windows
applications. The interface consists of the main menu, toolbars, and various windows. Its
structure is as follows:

· The main menu gives access to all program functions. The most important functions can also
be accessed via the toolbars.

· The toolbars contain functions exclusively related to CNC control. Functions related to data
processing (e.g., editing drawings) are also represented by icons and are located in the Tool
Palette window.

· All windows can be moved, hidden, or displayed. To show a window, go to the main menu
under Window and check the desired entry.

· In the 2D window, the machine area is displayed by default as a white rectangle. It also
shows the current position of the CNC machine, the loaded milling file (for example, a G-
code file), and other CNC elements such as the zero point, park point, measurement point,
and tool changer.

· The user interface can be reset to its default layout via View → Reset Toolbars in the main
menu.

3 Machine Parameters

 Warning: For the CNC machine to operate correctly, the machine parameters must be
configured. Missing or incorrect parameters may result in malfunction and can even cause
damage.

There are several ways to set up the machine parameters:

Load settings:
If an SBF2 or SBF8 configuration file (provided by the machine manufacturer or from a backup)
already exists, the settings can be restored by selecting this file from the menu Settings →
System Settings → Restore. This also applies to the conf ig.xml file. For more details, see the
chapter Settings.

Setup Wizard for Machine Parameters:
Machine parameters can be configured with the help of this wizard. Please note that the wizard
only performs basic configuration. Parameters may need to be fine-tuned manually or additional
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parameters configured afterward. The wizard can be accessed via Settings → Machine
Parameters → Setup Wizard.

Manual configuration of machine parameters:
A step-by-step explanation of the individual parameters can be found in this chapter. As
additional guidance, our YouTube channel youtube.com/@cncgraf provides a series of videos
explaining manual CNC machine setup.

Switching between different machine types:
To allow quick switching between different machine types, machine parameters can be saved
and loaded separately. All machine parameters are stored in XML format in the cncGraF 8
machine subdirectory. They can be saved or loaded via Settings → Machine Parameters →
Open/Save.

Importing machine parameters:
Individual machine parameters can be imported or exported through the menu Settings →
Machine Parameters → Open.

Figure: CNC milling machine and axis assignment

https://www.youtube.com/@cncgraf
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3.1 A First Overview

The Machine Parameters dialog contains all settings related to the functionality of the CNC
machine. The machine parameters can be accessed from the main menu via Settings →
Machine Parameters → Adjust... or by pressing the [F8] key. On the left side, a navigation
bar is provided. The parameters are logically grouped into the following categories: General,
Axes, Pin Assignment, Speed, Sensors, Tool Changer, and Extras.

Protecting machine parameters with a password
The machine parameters, as well as other important settings, can be protected against
unauthorized changes by using a password. This password can be set up via Settings →
Machine Parameters → Password.

 It is advisable to define a password hint (a phrase or keyword). If you ever forget your
password, this hint will serve as a reminder.
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3.2 Connection

To set up the CNC machine, a USB connection to the controller must first be established. This
requires installation of the USB driver. A detailed guide to installing the USB driver can be found
in the Installation chapter. Afterward, select USB as the connection type.

Read Interval
The cncGraF 8 software reads the machine status (axis positions, output states, etc.) from the
smc5d controller at fixed intervals specified in milliseconds. Increasing the read interval value
lengthens these cycles, reducing system load.

Timeout
In case of communication issues, cncGraF 8 attempts to maintain the connection with the smc5d
controller. If the software does not receive a response from the controller within the preset time
(for example: 2 seconds, see figure), the process is aborted and an error message is displayed
indicating that the connection was lost.

 In cases of severe interference, the disturbance may affect the connection to such an extent
that cncGraF 8 freezes. In such situations, disconnecting the USB connection (unplugging the
cable) can help.

Frequency
Some control electronics require a clock signal for enabling. To activate the clock signal, the
checkbox for the output must be selected. The clock signal can be set in a range from 1 to 25
kHz.

Multiple Instances
Instances make it possible to connect multiple controllers to a single PC via USB, allowing one
PC to control several CNC machines simultaneously. Up to four controllers can be operated at
the same time. To identify each controller, their serial numbers must be entered. Multiple
instances with the corresponding serial numbers allow cncGraF 8 to be launched multiple times.

 You can find the serial number by opening cncGraF 8 and selecting Help → About... from
the menu.
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LAN Connection
After establishing a USB connection, the smc5d-m4 controller can be switched to Ethernet. To
do this, select LAN as the connection type.

In the IP Conf ig dialog (opened via the IP Config button), you can configure the IP address,
gateway, subnet mask, and DHCP settings.

 The parameters in the IP Conf ig dialog must first be transferred to the controller via USB!

There are two methods to connect the controller via LAN:

Connection through a server:
Automatic connection using a hostname (DHCP) or a fixed IP address.

Direct connection to the PC (recommended):
A fixed TCP/IP address must be configured on the PC (Windows). Click the Network
Connections button to go directly to the Windows network settings. Select the Ethernet icon of
your network card. Open the context menu with a right-click and choose Properties. Then
select Internet Protocol Version 4 (TCP/IPv4) and enter the fixed IP address of the PC.

A video tutorial for LAN setup is available on our YouTube channel: https://youtu.be/bKFt-
ieSk5c

https://youtu.be/bKFt-ieSk5c
https://youtu.be/bKFt-ieSk5c
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3.3 Slave Connection

Expansion with additional controllers
This option allows the connection of additional controllers, which can be controlled via macros.
Macros can be called at various points in the machining process, enabling the CNC machine to
be integrated into automation workflows and allowing additional external devices to be
incorporated into the process.

In the Master S/N field, enter the serial number of the CNC machine. The list of slave
controllers, referred to here as Slave Controllers, contains the additional controllers. These
slave controllers are controlled via macros.

Example of a macro

string theSN = "01-1015-8164615";
Macro theMacro = new Macro(this.Context.Parent);

De.Boenigk.SMC5D.Basics.Connector 
theConnector = theMacro.GetSlave(theSN);

if(theConnector == null) {
    theMacro.MessageBox("Controller " + theSN + " nicht gefunden!");
    return;
}

De.Boenigk.SMC5D.Basics.Switch theSwitch = 
new De.Boenigk.SMC5D.Basics.Switch(theConnector);

theSwitch.SetPin(Output.Con2Pin1, true); // Ausgang 1 auf Slave-Controller schalten

if(theConnector.IsInputOn(Input.Con2Pin7, true)) { // Eingang 7 auf Slave-Controller prüfen
    theMacro.MessageBox("Ausgang 7 ist an");
    return;
}

 For more information on macros, see the chapter Macros.
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3.4 Power Stages

In the Power Stages menu, several parameters are available to ensure that as many power
stages/servos as possible can correctly interpret the clock signals from the smc5d controller.
Some power stages already provide predefined parameter sets that only need to be selected.
For power stages without predefined parameters, the settings must be configured manually.

· Power Stage: Select predefined parameters for your power stage.
· Name: Name or designation of the power stage/servo.
· Frequency: The smc5d controller can output step frequencies of up to 300 kHz (depending

on controller type) for interpolated movements across 6 axes plus dual-drive X/Y. At 150
kHz, the pulse length is 3.333 µs. If the pulse length is too short, it may cause malfunctions in
the power stage. In this case, the frequency must be reduced to ensure a sufficient pulse length.

· Invert Clock: Depending on the power stage, the clock signal may start with 0 or 1. An
incorrect setting can lead to lost steps.

· Step/Direction Delay: Some power stages (drivers) require a short delay after a change in
direction. An incorrect setting can also lead to lost steps.

 Always check the documentation of your power stages to determine the maximum
frequency and the allowable step/ direction delay.
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3.5 Axes

The cncGraF 8 software and the smc5d controller allow control of up to six axes (X, Y, Z, A, B,
C) using the Cartesian coordinate system. The origin of the X, Y, and Z axes is located at the
lower left. After homing, the X and Y counters for the absolute machine coordinates are set to
zero/axis length (see Ref erence Point), and the Z counter is set to the configured Z-axis length.
Note: When the Z-axis moves downward, the Z counter value decreases.

Figure: Cartesian coordinate system

 Before configuring the axes and additional parameters, make sure your machine is aligned
to match your own working position. This will simplify the setup process. The Axes section
provides instructions for configuring your machine’s axes.

3.5.1 Travel Range and Travel Range Monitoring

Travel Range
In the Travel Range section, the working area of the machine is defined. The values entered here
correspond to the maximum area that the machine can process. These values can either be taken
from the machine’s manual or determined by measurement.

 If you need to measure the travel range manually, keep in mind that you must not only
measure the pure axis length. You also need to consider the spindle clamping device — the
corresponding values must be subtracted from the total axis length.

Travel Range Monitoring
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Travel range monitoring provides software-based supervision of each axis. This function prevents
the machine from moving beyond its maximum travel limits, which could otherwise cause
damage. In this example, for the X and Y axes, the monitored range extends from a minimum of
0 mm up to a maximum of 300 mm for X and 440 mm for Y. For the Z-axis, however, a
minimum value (Z min.) must be defined to ensure that the spindle head does not crash into the
worktable (here: min. 15 mm).

In addition, the reference switches are used for monitoring. By specifying the current tool length,
the variable monitoring of the Z-axis minimum is activated (option Last Tool Length
Measurement Point). Each new tool length is subtracted from the tool length specified in the
input field to determine the new minimum Z height.

 However, travel range monitoring will only work reliably if the machine positioning is
accurate (i.e., no steps are lost). Further information on monitoring can be found in the chapters
Options → Messages, Safety Settings for Tool Changer, and Safety Zones.
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3.5.2 Dual Drive

The dual drive allows the X- or Y-axis to be operated with two motors. Both motors receive the
same step and direction signals. Activation is done in Machine Parameters → Axes for X/X2
or Y/Y2.

Homing
· For X/X2, two separate homing switches are required.
· The switches are configured under Machine Parameters → Pin Assignment.

Sequence
· Both motors move simultaneously until the first switch is triggered.
· After that, the second axis continues to move until the second switch is also triggered.

 Note: The homing switches should be placed as close to each other as possible.

Bridge Alignment
Since machine bridges are often not perfectly straight, a small correction distance can be
specified for fine adjustment. This allows the bridge to be aligned precisely.
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3.5.3 Axis Resolution

The first step in setup is to determine the axis resolution. This varies depending on the machine,
since different types of axis drives (e.g., lead screw, timing belt, gearbox) and drivers are used.
To calculate the axis resolution, you need the number of steps per revolution as well as the travel
distance per revolution. These values can be found in your machine’s user manual.

 The number of steps per revolution is defined on the stepper motor driver (or servo), e.g.,
1600 steps/rev. This value must then be entered into the corresponding field. The travel distance
per revolution is the distance in millimeters that the lead screw, timing belt, or gearbox moves the
axis in one full revolution.

After the values have been entered, cncGraF 8 calculates the axis resolution (mm/step) and the
maximum possible speed (mm/sec) of the machine, displaying them below the corresponding
fields. Using the checkboxes next to the axis labels, each axis can be enabled or disabled. In a
standard three-axis configuration, only X, Y, and Z are active. The A, B, and C axes can be
used for special tasks such as rotary or swivel movements.

 To ensure optimal axis interpolation (simultaneous movement of multiple axes), all axes
should have the same axis resolution. This improves the smoothness of machine operation.

 Even if the CNC machine cannot mechanically achieve very high resolution, it is still
recommended to set the axis resolution as high as possible — for example, 6400 steps per
revolution with a travel distance of 10 mm per revolution. This results in a resolution of
0.0015625 mm per step. Such a high resolution makes it possible to select a finer arc resolution
for the drawing .

Dual Drive
The X or Y axis can be operated with two motors. Enable the dual drive option and select the
axis to be driven by two motors. Additional settings for operating an axis with two motors can be
found in the chapter Pin Assignment.

Axis Compensation

47
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The axis compensation function is used to correct inaccuracies in the lead screw, timing belt, or
gearbox. First, the inaccuracy along the X and Y axes must be determined. For this purpose, a
defined distance (e.g., every 200 mm) is traveled along the X-axis. The actual deviation (actual
distance – target distance, here 200 mm) is calculated and stored line by line in an ASCII file.

Example of an ASCII file:
0,005
0,00425
-0,00025
-0,004875
-0,009

Both the X and Y axes must be measured in this way. Each ASCII file contains the values for a
single axis, so two separate files are required. These files must be provided along with the actual
travel distance, in this case 200 mm.

 Warning: Axis compensation is still in the testing phase!
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3.5.4 Homing

Reference Point
First, you need to define where the reference switches are located and in which direction the
axes must move to reach the reference point. As shown in the diagram, there are four possible
reference points (A, B, C, and D), each representing a corner of the working area. Example: If
the reference point is at the lower left, with coordinates X=0 and Y=0, then reference point A
must be selected.

Switch Release (Reference Switch Back-Off)
The Ref erence Switch Back-Of f  settings ensure that the switch is completely released (not
activated) after being triggered. The required values can either be found in the technical
specifications or determined experimentally (the distance from the switching point until the switch
is fully released).

Safety Distance for “Accelerated Homing”
In the next step, the safety distance for accelerated homing is defined. In this mode, the machine
moves at rapid speed (maximum speed) toward the reference points. The value entered defines
the position at which the rapid movement stops and the slower approach to the reference point
begins. In the example shown, the machine moves on the X- and Y-axes to within 20 mm of the
zero position, and on the Z-axis to within 20 mm of Z-max.

 After cncGraF 8 is started for the first time, a normal homing cycle without acceleration
must be performed, since the program does not yet know the axis positions. Accelerated homing
can then be enabled in the Homing dialog (key [F12]).
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Disable Homing for A/B/C Axes
Homing for the A/B/C axes can be disabled. In the figure below, homing for the A axis is
deactivated. Instead, the A axis position is set to 100 mm.

Once these values are defined, the inputs for the reference switches as well as the travel
directions must be configured. This is done in the Pin Assignment menu.

3.5.5 Tangential Axis

For cutting materials such as leather or cardboard, a tangential knife is used. This knife
automatically aligns itself with the cutting direction of the material using a stepper or servo motor.
Both single- and double-edged knives can be used, although double-edged knives are
recommended.

 Using a tangential knife requires a 4-axis control. In addition to the X, Y, and Z axes, an
extra stepper motor is needed to control the knife. Before the tangential axis can be activated,
the A axis must be enabled in the menu Machine Parameters → Axes.

Axis A / Axis B
cncGraF 8 can control up to two tangential axes. The settings for each tangential axis are
configured under the Axis A and Axis B tabs.

Steps per Revolution
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Specifies the number of stepper motor steps required for one full revolution. For more details,
see the chapter Axis Resolution.

Lift-Off Angle
This value defines the angle in degrees between two vectors at which the tangential knife can
remain in the material while rotating. If this angle is exceeded, the knife is lifted out of the
material, aligned with the cutting direction, and then plunged back into the material.

 To avoid damaging the material, the angle should not exceed 45 degrees. However, if the
angle is set too small, the machining process may take significantly longer. Therefore, a balanced
compromise should be chosen.
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Rotation Angle Limit
If the angle is less than or equal to the value defined as Rotation Angle Limit, the knife rotates
during motion until the desired travel direction is reached. If the vector angle exceeds the
specified value, the knife stops and is aligned accordingly. The motion then continues (with the
knife remaining in the material). To avoid damaging the material, only a small angle — up to
about 10 degrees — should be entered.

Use Feed and Lift Speed
This function overrides the rapid speed of the Z-axis and allows separate speeds to be set for
plunging and lifting. The Z feed speed defines the knife’s plunge speed into the material, while the
lift speed defines the speed at which the knife is retracted from the material.

Reset A/B Position after Homing
For the knife to operate correctly, it must be aligned as precisely as possible along the X-axis
(parallel to X) after homing. The alignment can be performed manually by hand or via software.
The software-based alignment has the advantage of greater accuracy. To align the knife using
software, proceed as follows:

The function Reference Switch Back-Off A/B is used for alignment. A travel distance is
specified in steps, ensuring that the knife is aligned exactly parallel to the X-axis.

 The more precise the alignment, the better the cutting results. To verify alignment, run a
simple drawing consisting of two horizontal lines.

The function Reset A/B Position after Homing must be enabled so that the A/B axis is reset
to zero after back-off (equivalent to homing without subsequent back-off).

Switch Outputs
Here, outputs can be switched either globally for all tools or tool-specific. This is required for Z-
axes without a stepper or servo motor, which are lowered and raised via an output.
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3.5.6 Rotary Axis

Depending on the number of axes supported by the controller, the rotary axis can be used in two
different operating modes:

4-Axis Control
By enabling the 4th axis, it can be defined as a rotary axis. The rotary axis can be mounted on
the worktable either in the X or Y direction.

 If the G-code file (DIN 66025) contains coordinates for all four axes (4D machining), then
the choice of axis direction only affects how the rotary axis is displayed on the screen.

3-Axis Control
With 3-axis control, the 4th axis must be disabled. The rotary axis is connected to the X and Y
outputs by swapping the plugs.

Symbolic Representation of the Rotary Axis
Once the rotary axis has been enabled in Machine Parameters → Axes → Rotary Axis, a
line of length U = D × P is displayed, where D represents the diameter of the material. From the
starting point of this line, a second line is drawn at a right angle, representing the rotary axis. A
third, dashed line marks the circumference of the material.

3.5.7 Z2

The Z2 function allows CNC machines to operate with a dual Z-axis.

First, the axis for Z2 operation must be enabled in the Axes menu. Then, select the appropriate
operating mode for the axis designated as Z2. After that, the distance between the Z and Z2 axes
in the X or Y direction must be specified. The Z2 axis can also be used in combination with the
tangential axis.



31Machine Parameters

Copyright © 1993 - 2025 by BOENIGK-electronics

3.5.8 Backlash

Backlash refers to unwanted play (slack) between the screw and nut, or between the pinion and
rack of a mechanical drive. It may occur when the travel direction is reversed. To compensate
for possible backlash in the machine, the corresponding values can be entered in this dialog. The
settings can be specified either in millimeters or in steps.

3.6 Pin Assignment

In the Pin Assignment section, functions such as spindle, collet, reference switches, buttons,
travel direction, and many other features controlled via inputs and outputs are configured.

The pin assignment settings can be found in the menu under Settings → Machine Parameters
→ Adjust → Pin Assignment.

 If the CNC machine has not yet been fully configured, it is recommended to begin this
chapter with the configuration of the ref erence switches. The homing procedure must always be
performed first, since otherwise cncGraF 8 does not know the machine’s position.

3.6.1 Reference Switches

In the Pin Assignment section, the settings for reference switches and travel directions are
defined, among others.

1. Preparations for the first homing cycle
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First, the inputs of the reference switches should be checked. From the main menu, select View
→ Set Reference Point to set the reference point. This step is required to enable axis
movement. The reference switches must be in the NOT PRESSED state, meaning the switches
should be free. If an axis is positioned on a reference switch, it can be moved away from the
switch using the control keys in Manual Move (note that the travel direction of the axes may
not yet be correctly configured).

To check the inputs of the reference switches, click the green/blue USB/Ethernet icon in the
status bar at the bottom (see figure).

The window for monitoring inputs and outputs will open. Press each reference switch one after
the other. If the status of an input changes from gray to green or vice versa, the corresponding
pin has been identified. Enter the pin number for each axis in the menu Machine Parameters →
Pin Assignment → Inputs for Reference Switches.

Are the reference switches “normally open” or “normally closed”?
Another important step is to check whether the reference switches are configured as normally
open or normally closed (the switches should still be in the NOT PRESSED state). To
determine this, you can start the Reference Switch Wizard. The wizard automatically detects
whether the switch is normally open or normally closed and sets the corresponding checkbox.
Example: In the figure below, the checkbox for the Z-axis was set by the wizard.

 A normally open switch interrupts the circuit when activated, while a normally closed
switch closes the circuit when activated.

Homing Sequence
Next, the Homing Sequence is defined — that is, the order in which the axes are moved during
the homing cycle. It is recommended to use the sequences ZXYAB or ZYXAB. Variants such
as XZYAB or YZXAB are not advisable, since the Z-axis would not be released first, creating a
risk of the cutter colliding with the workpiece.

2. First Homing Cycle
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The homing cycle can be executed from the main menu via Move → Home... or by pressing the
[F12] key.

 Attention: Pay close attention to the travel direction during the homing cycle! If an axis
moves in the wrong direction, stop immediately, invert the homing direction in Machine
Parameters → Pin Assignment (see figure), and restart the homing cycle.

3. Final Check of Homing Settings
The homing cycle consists of two steps:

· First, the machine moves toward the reference switch at homing speed.

 The homing speed and acceleration must be set so that the machine can stop behind the
reference switch, since the braking distance is limited.

· Once the reference switch is triggered, the axis stops and then moves away from the switch at
start/stop speed until the switch is released again.

4. Check Travel Direction
Next, the travel direction of the X, Y, and Z axes must be verified. To do this, move each axis in
the Manual Move window. If an axis moves in the wrong direction, the orientation can be
corrected in Machine Parameters → Pin Assignment → Travel Direction by inverting the
checkbox for the corresponding axis.

3.6.2 Defining Inputs and Outputs

Once the reference switch configuration has been completed, the outputs for the spindle, pump,
and collet can be defined. In addition, the inputs for the tool length sensor, zero-point sensor (X,
Y, and Z axes), and depth probe can be configured.

Invert Inputs
In some cases, inputs need to be inverted because a switching state operates in reverse. A good
example is the tool length sensor. It should switch of f  when pressed — meaning that in its
unpressed state the input is active (the input indicator lights up).
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The advantage of this configuration is that if the sensor fails, the machine will not continue to
move onto the sensor and risk damaging it. The software assumes the switch is already pressed.
In this case, the Z-axis will move slowly upward until it reaches the reference switch, and then
stop.

Debounce Time
Debounce time refers to the delay applied to ignore false signals caused by the mechanical
bouncing of a switch. When a switch is pressed, vibrations may cause the contact to briefly open
and close multiple times before stabilizing. This disturbance is called bouncing. The debounce
time ensures that only stable signals are recognized as valid switch states. Debounce time is
specified in microseconds and defines the shortest switching time that will be accepted as valid,
effectively filtering out noise.

 Warning: The higher the debounce time, the less precise the switching point becomes.
Therefore, the debounce time should be kept as short as possible.

Invert Con2/3/4
The smc5d controller has several outputs on the Con2, Con3, and Con4 interfaces. When the
controller is powered on, these outputs are set to a predefined state.
Example: If a pump connected to Output 2 starts immediately when the controller or the entire
system is switched on, this output must be inverted in the Invert Con section. This prevents the
pump from being activated automatically at startup.

3.6.3 Hood and Emergency Stop

Under Machine Parameters → Pin Assignment → Hood and Emergency Stop, safety
functions are defined. There are two areas: Hood/Door/Light Curtain and Emergency Stop .
All functions are controlled via inputs.

Hood/Door/Light Curtain
In this area, machine hoods, doors, and light curtains are monitored through inputs. For example,
a hood can be secured via an input. The Setup Mode option allows slow manual movement of
the CNC machine while the hood is open.

Emergency Stop
Here, any number of inputs can be defined as error signals. The Emergency Stop Settings
dialog is divided into three sections:

1. Input Settings: Defines the input used for the error signal. To ignore faulty input signals, you
can configure how many checks are required before the input is considered active, as well as
the startup delay (in seconds after beginning the machining process).
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2. Filter in Automatic Mode: Determines when an error is recognized as valid. Various
options are available, such as Error only f or a specif ic tool number or Error only if  an
additional output is active. Example: If Input 21 switches off (inverted) while Tool 1 is in
use (milling process) and Output 14 is active, the process will be aborted and an error
message will be displayed.

3. Action: In the final section, you define which action is triggered when the error condition
(consisting of input and filter) is met. The process will be aborted and a specified error
message will be displayed on the screen. Optionally, an output — for example, to flash an
external red warning light — can be activated, or the machining speed can be reduced.

 Warning: Since Hood and Emergency Stop  is a purely software-based solution, it does
not provide the same level of safety as a hardware-based solution. A hardware solution should
therefore always be preferred.

3.6.4 Outputs

In the Outputs menu, you can specify whether an output should be activated at the end of the
homing cycle or after moving to the park position. In the figure below, the setting Af ter Homing
is active.

3.7 Speeds

In this section, the speeds for rapid traverse, homing, and start/stop movements are defined. The
speed settings can be found in the menu under Settings → Machine Parameters → Adjust
→ Speeds.

 It is recommended to set the rapid traverse speed first, then the start/stop speed, and finally
the homing speed.
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3.7.1 Rapid Traverse Speed

The rapid traverse speed is the maximum speed at which the machine can move. If the machine
comes from a third-party supplier, the maximum speed can usually be found in the
manufacturer’s manual. If this information is not available, the maximum rapid traverse speed
must be determined through testing.

When is the maximum possible speed reached?
The maximum speed is reached when the machine begins to lose steps outside the tolerance
range of less than 0.1 mm (see also the section Check f or Lost Steps).

3.7.2 Start/Stop Speed

The start/stop speed defines the speed at which the machine begins to move and comes to a
stop. This value must be set according to the performance of your machine. It should not be set
too high, as this can lead to lost steps. Some machines can handle a starting speed of 8 mm/sec,
but this is an exception. Therefore, it is recommended to choose a lower value. The achievable
speed depends on the stability and rigidity of your machine.

 Once the appropriate values have been entered, you can continue with Homing Speed.
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3.7.3 Homing Speed and Acceleration

 The homing speed should not be set too high, since the axis must be able to come to a stop
in time after passing the reference switch. It is recommended to start with a low homing speed.

Enter the values in the field shown below:

Acceleration
Once the corresponding values have been entered, the ramp for the homing cycle must be
defined. It is recommended to select the highest possible ramp setting so that the braking
distance after the reference switch remains as short as possible, allowing for a higher homing
speed (shorter waiting time).

The acceleration can be adjusted using the slider. The higher the value displayed in %, the
steeper the acceleration ramp — resulting in a faster process. In addition, the ramp can be
influenced by selecting the ramp prof ile type. Changing the type affects the acceleration and
deceleration paths. By default, the type is set to Level 1 (on a scale of 1 to 6). The higher the
selected value, the steeper the ramp. However, changing the type is only recommended for very
stable machines capable of relatively high maximum speeds (e.g., 500 mm/sec). For most cases,
it is recommended to use Type 1.
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How to Check if the Acceleration Ramp is Set Correctly
To verify this, perform a homing cycle. If the machine hits the mechanical limit (clearly audible),
the slider value must be increased and/or the homing speed reduced. Repeat this process until the
optimal speed is reached.

Afterward, the acceleration value for milling, drilling, or moving can be set separately. This value
may differ from that of the homing cycle and depends on the rigidity of your machine.

Reduce Jerk
With “poor” data, such as circles with coarse resolution, and at high feed rates, the machine may
accelerate and decelerate repeatedly in quick succession. This behavior can cause jerking.
Activate the Reduce Jerk option to achieve smoother motion.

 Although the Reduce Jerk option improves motion smoothness, it also increases the
machining time.

Constant Feed Rate
This option affects the machine’s behavior during diagonal (interpolated) movements or circular
motions, where two motors are always driven simultaneously. During diagonal travel, the distance
covered is longer than in movements along only the X or Y axis. For example, if the axis speed is
set to 20 mm/sec, the machine will attempt to maintain this value.
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Function Active:
When this option is enabled, the controller adjusts the motor speeds so that the feed rate remains
constant at 20 mm/sec, even along interpolated paths (Vector 3).

Function Inactive:
When constant feed rate is disabled, longer interpolated paths (Vector 3) are traversed in the
same time as shorter paths, resulting in a higher actual travel speed.

3.7.4 Probing Speeds

The probing speeds define how fast the machine approaches the 3D probe, the tool length
sensor, and the sensor for scanning three-dimensional objects. To prevent damage, the speeds
for the 3D probe and the tool length sensor should be set low, since the braking distance is short.

3.8 3D/Surface Probe

In the 3D/Surf ace Probe section, the calibration values determined during the automatic
calibration of the 3D probe are displayed. These values should not be changed unless there are
deviations — for example, in the ball diameter of the 3D probe — which may need to be
adjusted manually.
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 Warning: When probing surfaces, a 3D probe with a ball tip must not be used, as this can
cause inaccuracies. In such cases, a pointed tip must be used.

3.9 Automatic Tool Changer

An automatic tool changer is a device for picking up and releasing tools. The cncGraF 8
software distinguishes between two variants: the Z-axis tool changer and the X/Y-axis tool
changer, which differ in their travel paths. In addition, rotating tool changers can also be
operated, controlled by an additional stepper motor. The tool changer settings can be found in
the menu under Settings → Machine Parameters → Adjust → Tool Changer.

 Apart from these two variants, cncGraF 8 also supports other types of tool changers via
the macro function. For more information, see the section Macro Editor. 
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3.9.1 Configuring the Tool Changer

Setting up the Z-Axis Tool Changer

Properties
Under Properties, the following parameters are defined: dwell time, insertion speed, lift speed,
Z-travel, and Z-height. In addition, you can specify whether a homing cycle should be executed
after each pick-up or release operation. You can also configure the tool numbering to start at T0.

· Dwell Time
Defines how long the spindle should remain above the tool position before the next action is
executed. This is the time the collet requires to grip or release the tool. The value may vary
depending on the manufacturer. If no information is provided, the time should be determined
experimentally.

· Insertion Speed
Determines the speed at which the tool is moved into the tool changer. This value should be
kept as low as possible to avoid potential damage to the tool or changer and to allow the
machine enough time to decelerate.

· Lift Speed
Defines the speed at which the tool is removed from the changer. This can be higher than the
insertion speed.

· Z-Travel
Specifies the distance along the Z-axis where the tool is moved into the changer at reduced
speed until it comes to a stop. This value is determined by manually moving the machine to the
start position of the slow approach in Z, then setting the relative Z-value in the main window to
zero. Continue moving the Z-axis until the end position of the tool in the holder is reached. The
value displayed under RZ corresponds to the Z-travel value.

· Z-Height
Defines the safe clearance height in the Z-axis used when approaching the tool. This value
cannot be set lower than the Z-value entered under Position of  the First Tool. If a lower
value is entered, cncGraF 8 automatically resets it to the Z-value of Position of  the First
Tool.

Under Properties, you can also configure the display color for occupied and free tool positions,
and specify whether a homing cycle should be performed before placing a tool back. This option
is useful if the machine has lost steps during machining and can no longer approach the tool
changer position correctly.
If the checkbox for T0 is enabled, tool numbering begins at T0 (whereas in DIN-ISO files tools
usually start with T1). Another option is Close Collet: when enabled, the collet closes after each
pick-up and release operation, preventing continuous air flow.
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· Variable Placeholders
This option allows arbitrary tool numbers to be assigned to a tool changer placeholder. The
tool number is entered in the T/P field of the Distance table.

· Blow-Off
Specifies which output is used for the Blow-Of f  function. You can configure whether the
function runs permanently or for a specified period of time. Blow-Of f  is intended to remove
material residues from the collet, but it can also be used to control a cover for the tool changer.

· Position of the First Tool
Here, the position of the first tool in the holder is defined. To determine the values: move the
machine to the exact position of the first tool holder (in Z, to the start position of the slow
approach). Then left-click Set Current Position. The X, Y, and Z coordinates are
automatically entered into the respective fields.

· Distance
Click Add to add the first tool to the tool list (the X, Y, and Z values remain at 0). Next, add
another tool position in the same way, but this time enter a value (the center-to-center distance
from Tool 1 to the next tool) in X or Y, depending on the orientation of the tool changer. A
deviation in Z can also be corrected by entering a value. Repeat this process until the maximum
number of tool positions is reached. After the parameters are entered, the tool changer
appears in the main window’s workspace. Tool positions can also be edited as absolute
positions by enabling the Show as Absolute Position option.
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Setting up the X/Y Tool Changer

The setup of the X/Y tool changer is identical to that of the Z-axis tool changer, with the only
difference being that the Z-travel is not specified. Instead, the X/Y-travel is entered in the X/Y
Distance field, since the tool change takes place from the side rather than from above along the
Z-axis.

3.9.2 Safety Settings

Tool Monitoring
The tool monitoring parameters ensure that a tool is correctly picked up or released. If the
spindle is equipped with an automatic collet that provides a monitoring contact, this can be
connected to the smc5d controller, and the corresponding input can be specified here.
Monitoring can be performed either with the option Check if a tool is present or Check if the
tool has been released.

Another monitoring method is Check if the tool has been released using a tool length
sensor. In this case, the machine moves to the tool length sensor down to a defined minimum
Z-height. If the tool length sensor is triggered, it means the tool has not been released, and an
error message is displayed.

Relative Travel
The values under Relative travel to/from the tool changer define the safe X- and Y-distances
that the machine should move before and after picking up or releasing a tool. The same applies to
the values under Relative travel to/from tool measurement.

Spindle Stopped
A spindle that activates a contact when it stops can be monitored by cncGraF 8. In this case, a
waiting window is displayed until the corresponding input is triggered.

Tool Changer and Tool Measurement Outside the Machine Area
The parameters Allow tool length measurement outside the machine area and Move to
position at end of operation make it possible to place the tool changer and the tool length
sensor outside the machine’s working area. The value for Move to position at end of  operation
specifies the location the machine should move to after a tool change or tool measurement,
ensuring that the CNC machine is back inside the working area once the operation is completed.

3.10 Swivel Arm

The swivel arm allows the surface probe to be automatically lowered or raised.

The swivel arm settings can be found in the menu Settings → Machine Parameters → Adjust
→ Extras. The swivel arm is controlled via an output. The dwell time defines how long it takes
for the swivel arm to fully move down or up. An input can be used to check whether the swivel
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arm is in the lower or upper position. The swivel arm can be used both for Surface Probing and
Zero-Point Detection.

3.11 Vacuum Table

Sections of the vacuum table can be automatically switched on or off during the milling process.
The corresponding settings are located in the menu Settings → Machine Parameters →
Adjust → Extras.

In the table, multiple vacuum table sections can be defined, each with associated outputs. These
sections can also be displayed in the 2D view for verification (View → Vacuum Table).

Control Modes
The vacuum table can be controlled in different ways:
· Permanent: All vacuum table outputs are switched on at the beginning of the milling process

and remain on until the end.
· Area Activation: When the cutter enters a vacuum table section, that section is switched on

(output enabled) and remains on until the process is complete.
· Variable Area Control: A section is switched on as soon as the cutter enters it and

switched off again once the cutter leaves the area.
· Permanent – Only Used Sections: All required outputs (depending on the drawing data)

are switched on at the beginning of the milling process and remain on until the end.

3.12 Final Check

This section outlines some final checks for your machine and its settings. If all machine
parameters are configured correctly but lost steps or inaccurate machining results still occur, the
cause may be an incorrect step signal configuration of the drivers or insufficient power supply to
the motors.

Here are some suggestions for troubleshooting such cases:
· Check the driver timing
· Test the motors
· Verify the axis resolution
· Check for lost steps
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3.12.1 Check Driver Timing

Stepper motor drivers typically use the Active Low configuration for clocking the step and
direction (DIR) signals. However, some drivers operate with an Active High configuration. The
cncGraF 8 software is set to Active Low by default.

The step pulses are represented graphically as follows:

Depending on the driver used, the checkbox Invert Clocking must be set in the menu Settings
→ Machine Parameters → Adjust → Drivers. If the checkbox is not set, Active Low
(illustration with 0) is active. If the checkbox is set, the clocking changes to Active High
(illustration with 1).

 Warning: It is essential that all drivers operate with the same clocking mode. Using
different modes may result in misinterpretation of the signals.

Modern drivers often also allow switching the clocking mode directly via a physical switch on the
driver itself.

3.12.2 Motor Test

Current reduction is a function that prevents stepper motors from overheating and being
damaged while at standstill. This function can be enabled in the menu Settings → Machine
Parameters → Adjust → Pin Assignment, where a shut-off delay can also be defined.

To check whether current reduction is working correctly, allow the motors to remain idle for a
while and then measure their temperature. If the motors are “cool,” current reduction is
functioning properly. If not, the function must be inverted by enabling the checkbox Reduce
Motor Current (Pin 8) under Con2 in the menu.

In the previous section Driver Timing, incorrect clocking was mentioned as one possible cause
of lost steps. If the clocking is configured correctly, another cause of lost steps may be
insufficient motor supply voltage. In this case, you should verify whether the drivers are providing
the correct voltage for the motors.

3.12.3 Check Axis Resolution

To verify the axis resolution, proceed as follows:

X and Y Axes:
1. Place a sheet of paper on the machine’s worktable and mark the starting point of the cutter.
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2. Using the manual machine control (Manual Move) in the cncGraF 8 main window, enable
Relative Travel and enter a distance of 100 mm (or another desired value) in one of the
fields. Then click the control icon for the axis you want to test.

3. The machine will move the specified distance of 100 mm.
4. Mark the cutter’s end position on the paper and measure the distance between the two

points.
5. If the measured distance equals the desired 100 mm, the axis resolution is correctly set. If

not, the axis resolution must be adjusted.

Z Axis:
1. Move the Z-axis to Z-max and measure the distance from the machine table to the Z-

spindle holder.
2. Using the manual machine control (Manual Move) in the cncGraF 8 main window, enable

Relative Travel and enter a distance of 100 mm (or another value). Then click the Z
control icon to start the movement.

3. Once the machine has reached the end position, measure the distance again from the
machine table to the Z-spindle holder.

4. If the difference between the start and end measurements matches the entered distance, the
Z-axis is correctly calibrated. If not, the Z-axis resolution must be adjusted accordingly.

3.12.4 Check for Lost Steps

How do I check for lost steps?
1. Load a file to be processed. The file should be large enough for the CNC machine to run for

about 30 minutes.
2. Set the Z zero point high enough so the CNC machine runs “in the air.”
3. Perform a homing cycle.

4. Click the Milling/Drilling icon  and let the machine process the entire file.
5. After the file has been fully executed, start Check Position... (Menu → Move → Check

Position...). A homing cycle will be performed and the results displayed.
6. If the position data of any axis is shown in red (outside the tolerance > 0.1 mm), this indicates

lost steps.

 Lost steps can have various causes, such as mechanical issues, incorrectly configured
drivers, excessive speeds, or even electrical interference. All of these factors should be checked.
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4 Introduction to File Processing

The cncGraF 8 software supports various file formats, including DIN 66025 (G-code), Isel
NCP, as well as 2D formats such as HPGL, DXF, PostScript, Adobe Illustrator, Excellon, Sieb
& Maier 1000, and Sieb & Maier 3000.

Processing G-code Files
G-code files are typical machine files for professional CNC machines and are usually
multidimensional (typically 3D, but 4D up to 6D is also possible). These files are generally
generated by CAD/CAM software, but can also be programmed manually using the integrated
text editor. This approach allows for the production of complex parts with virtually no limitations,
although it is relatively complicated for beginners.

Processing 2D Files
Formats such as DXF and HPGL are 2D files that can be easily created with any CAD
software. Since these files are not directly designed for CNC machining, they require some post-
processing. cncGraF 8 provides a tool palette that allows for straightforward editing, including
tool compensation, defining milling order, creating pockets with islands, and other simple
functions. This approach offers an easy way to quickly produce 2.5D parts. The advantage lies in
its simplicity, although it is suitable only for simple 2.5D parts.

Arc Resolution
Most file formats such as G-code, DXF, or HPGL contain arc and circle commands. However,
the smc5d controller does not support arc commands for technical reasons (the conversion
would be too computationally intensive for the controller and would drastically reduce its
frequency and speed). Therefore, these commands are converted into polylines. The arc
resolution can either be selected in the dialog that appears when opening the file, or later in the
menu Settings → Options → File.

 The arc resolution should be set neither too high nor too low. It should not exceed the axis
resolution of the CNC machine. An arc resolution about two to three times finer than the axis
resolution of the CNC machine is recommended. For this reason, it is advisable to set the
resolution to Medium or High.

 Even if the CNC machine cannot mechanically achieve a very high resolution, it is still
recommended to configure the axis resolution as high as possible — for example, 6400 steps per
revolution with a travel of 10 mm per revolution. This results in a resolution of 0.0015625 mm
per step. Such a high resolution allows the use of a finer arc resolution.
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“Open File” Dialog

Files can be opened via File → Open in the menu. The file type *.* displays all files. In this
case, cncGraF 8 automatically detects the file type. If the file type is not correctly recognized, the
specific type must be selected manually — for example, for G-code files: DIN 66025; ISEL
NCP (.nc; .ncp ).

 There are two different windows available for opening files: the standard Windows Open
File dialog and the cncGraF 8 Open File dialog with file preview. The desired window can be
selected under Settings → Options → File → Properties. The standard Windows Open File
dialog has the advantage of being faster, since it is integrated into the Windows system.
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4.1 G-code and the Postprocessor

Standardized G-code according to DIN 66025 is the standard format for professional machine
tools in the 2½D and 3D range. cncGraF 8 supports this standard as fully as possible and is
therefore compatible with all common CAD/CAM programs.

Postprocessor (PP)
The postprocessor (PP) defines how the G-code is generated for a specific CNC machine.
Although G-code is based on the DIN 66025 standard, differences in interpretation exist among
different CNC machines. These differences are described in the postprocessor. In CAD/CAM
programs, postprocessors can be customized to precisely adapt the G-code to the requirements
of the machine.

Overview of G-functions
· G00 : Rapid traverse
· G01 : Linear move with feed rate
· G02 : Circular interpolation clockwise
· G03 : Circular interpolation counterclockwise
· G04 : Dwell time
· G28: Move to Z reference point
· G28P: Move to Z reference point and XY park position
· G40 : Cancel tool radius compensation
· G41 : Activate tool radius compensation (tool left of contour)
· G42 : Activate tool radius compensation (tool right of contour)
· G53 : Cancel work offsets
· G54-G59 : Select work offset
· G60 : Re-select last canceled work offset
· G70 : Units in inches
· G71 : Units in millimeters
· G80 : Cancel drilling cycle
· G81 : Drilling cycle: simple drilling
· G82 : Drilling cycle: simple drilling with dwell at bottom
· G73/83 : Drilling cycle: peck drilling (fast/deep-hole with chip breaking)
· G84 : Tapping cycle (right-hand and left-hand threads)
· G87 : Circular pocket cycle
· G90 : Absolute programming
· G91 : Incremental programming
· G98 : Return to initial plane in drilling cycle
· G99 : Return to reference plane in drilling cycle
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Overview of M-functions
· M00: Program stop (program resumes after key press)
· M03: Spindle on (clockwise)
· M04: Spindle on (counterclockwise)

Note: Counterclockwise rotation is switched via a relay in the “DIN 66025 Properties” dialog.
· M05: Spindle off
· M08: Coolant on
· M09: Coolant off
· M20: Plasma torch off
· M21: Plasma torch on
· M30: End of program
· M48/M49 : Feed and spindle speed override enabled/disabled
· M995-M998 : Call a macro inside a DIN 66025 file

Comments
· ( .... ) Comments in round brackets.

Example: N01 G00 Z10 (Position Z10 anfahren)
· [ .... ] Comments in square brackets.

Example: N01 G00 Z10 [Position Z10 anfahren]
· ; Comments after a semicolon.
Example: N01 G00 Z10 ;Position Z10 anfahren

Other Commands
· F: Feed rate in mm/min
· N: Block number
· T: Tool number
· S: Spindle speed
· D: Tool diameter in millimeters (must be used together with tool number)

Example: T1 D2.5

Special Commands
· M99 P : Subprograms (modif ied!)
· G25-G26 : Loop
· R-Parameter : Variable
· IF-Anweisung : Conditional execution

Structure of a Block according to DIN 66025

No.
Function/Condi
tion

Coordinates
Spindle
Speed

Feed Rate Tool
Miscellane
ous

N G X Y Z A S F T M

62

62

61

53

63

64
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All commands can be written in lowercase and without spaces using any standard text editor.
The line number Nxx is optional and can be omitted, as it has no impact on program execution.

4.1.1 G00/G01 – Rapid Traverse and Linear Feed

With G00, the machine moves in rapid traverse, i.e., at maximum speed. This motion is
typically used for positioning moves where the tool is not cutting (air moves). With G01, the
programmed path is executed at the specified feed rate.

Parameters for G00 and G01
· X – Position on the X-axis
· Y – Position on the Y-axis
· Z – Position on the Z-axis
· A – Position on the 4th axis (the letter assigned to the 4th axis can be configured in DIN66025

Properties)
· B – Position on the 5th axis (the letter assigned to the 5th axis can be configured in DIN66025

Properties)
· F – Feed rate
· S – Spindle speed

Example
N01 G00 Z10 (Move to position Z10)  
N02 G00 X100 Y10 (Move to position X100 Y10)
N03 M3 M8  (Start spindle with M3 and coolant pump with M8)  
N04 G01 Z-2 F50 (Feed 2 mm into the workpiece at 50 mm/min)

N05 G01 X100 Y100 F100
N06 G01 X20 Y20 
N07 G01 X100 Y10

N08 G00 Z10 M5 M9 (Retract to Z10, stop spindle with M5 and coolant pump with M9)

N09 M30 (End program with M30)
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4.1.2 G02/G03 – Circular Interpolation

·  G02 is used to move along an arc in a clockwise direction.
· G03 is used to move along an arc in a counterclockwise direction.

The start point of the arc is always the current tool position. The end point of the arc is
specified with the X, Y, and Z coordinates in the G02/G03 command. The circle center is
defined by the offsets I, J, and K.

Parameters for G02 and G03

X – End coordinate in X direction

Y – End coordinate in Y direction

I – Circle center offset in X direction

J – Circle center offset in Y direction

K – Circle center offset in Z direction

Example 1 – Circular arc in XY-plane
N01 G00 X0 Y0 Z10 (Move to position X0 Y0 Z10)
N02 M3 (Start spindle with M3)

; Feed to X10 Y10 at 100 mm/min  
N03 G01 X10 Y10 F100 

; Feed into the workpiece 2 mm at 50 mm/min  
N04 G01 Z-2 F50 

; Circular arc from X10 Y10 to X30 Y10  
; with circle center at I20 J10  
N05 G02 I20 J10 X30 Y10 

; Retract tool by 10 mm
N07 G00 Z10 
N08 M30  (End program with M30) 

Example 2 – Thread milling
This program mills a thread with a pitch of 2 mm and a depth of 6 mm (3 turns). For a full circle,
the start point and end point are identical.

N01 G0 X500 Y500
N02 G0 Z-5
N03 G2 I550 J500 Z-7 F60
N04 G2 I550 J500 Z-9
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N05 G2 I550 J500 Z-11
N06 G0 Z0
M07 M30     (Activate M7, end program with M30)

4.1.3 G04 – Dwell Time

The G04 command programs a dwell, i.e., a pause in machine motion. For example, G04 H2
specifies a dwell time of 2 seconds.

This function is typically used to allow the spindle time to reach its operating speed before cutting
begins.

Parameters for G04
· H – Time in seconds

Example

; Hold the tool position for 2.5 seconds  
; (spindle continues rotating)  
N10 G04 H2.5

4.1.4 G25/G26 – Loop

With G25 and G26, a loop can be programmed.
· G25 defines the start of the loop.
· G26 ends the loop.
· The parameter Q specifies the number of iterations.

Example: Q5 → the loop contents are executed 5 times.

Note: The number of iterations has changed in the newer version. For example, Q2 now
means 2 iterations. In older program versions, it was 3 iterations.

Parameters for G25 and G26
· Q – Number of iterations

Loops can be nested arbitrarily, but they must not be defined inside subprograms.

Example
N10 T1 M3 S2501
N20 G0 X10 Y10
N30 Z-5 M8
N31 G04 H6
N40 G91
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N42 G25 Q2

N44 G25 Q4
N50 P1 (Call subprogram 1)
N51 G26

N60 G0 X-65 Y10
N62 G26

N44 G25 Q4
N50 P1 (Call subprogram 1)
N51 G26

N120 G90
N130 G0 Z0 M9
N140 M5
N150 M30 (End of program)

N160 M99 P1 (Start of subprogram 1)
N170 G2 I3.5 J0 Z-2 F360
N180 I3.5 J0 Z-2
N190 I3.5 J0 Z-2
N200 I3.5 J0 Z-2
N210 I3.5 J0 Z-2
N220 I3.5 J0 Z-2
N230 I3.5 J0
N240 G1 X3
N250 G2 I0.5 J0 Z-2 F180
N260 I0.5 J0 Z-2
N270 I0.5 J0 Z-2
N280 I0.5 J0 Z-2
N290 G0 Z20
N290 G0 X10
N300 M00
N310 M99 P0 (End of subprogram)

4.1.5 G40/G41/G42 – Tool Radius Compensation

The cncGraF 8 software supports the commands G40, G41, and G42. After loading a G-code
file that contains G41 or G42 commands, a radius compensation dialog window will appear.

Example
N10 T06 M03 S2000
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N11 M08
N12 G00 X1.700 Y0
N13 Z10.000
N14 Z-3.000
N15 G01 G41 X4.558 Y-1.650 Z-3.488 F250
N16 G03 X5.000 Y0 Z-3.743 I1.700 J0
N17 X-5.000 Y0 Z-4.671 I0 J0 F500
N18 X5.000 Y0 Z-5.600 I0 J0
N19 X-5.000 Y0 Z-5.900 I0 J0
N20 X5.000 Y0 Z-6.200 I0 J0
N21 X-5.000 Y0 Z-6.500 I0 J0
N22 X5.000 Y0 Z-6.800 I0 J0
N23 X-5.000 Y0 Z-7.100 I0 J0
N24 X5.000 Y0 Z-7.400 I0 J0
N25 X-5.000 Y0 Z-7.700 I0 J0
N26 X5.000 Y0 Z-8.000 I0 J0
N27 X-5.000 Y0 Z-8.300 I0 J0
N28 X5.000 Y0 Z-8.600 I0 J0
N29 X-5.000 Y0 Z-8.900 I0 J0
N30 X5.000 Y0 Z-9.200 I0 J0
N31 X-5.000 Y0 Z-9.500 I0 J0
N32 X5.000 Y0 Z-9.800 I0 J0
N33 X-2.500 Y4.330 Z-10.000 I0 J0
N34 X-2.500 Y4.330 I0 J0
N35 X-3.708 Y3.122 I-.850 J1.472
N36 G01 G40 X-.850 Y1.472
N37 G00 Z-3.000
N38 G90 Z10.000
N39 M09
N40 M05
N41 M30

  Warning: The calculated toolpath compensation must always be visually verified in the
2D/3D view to ensure accuracy.

4.1.6 G53–G60 – Work Offsets (Zero Points)

· G54 to G59 are used to select work offsets (zero points).
Example: G55 X20 Y10 applies an offset of 20 units in X and 10 units in Y.

· G53 cancels the currently active work offset.

· G60 reactivates the last canceled work offset.
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Parameters for G54 to G59
· X – Offset in X
· Y – Offset in Y
· Z – Offset in Z

Example
N10 G0 T01 Z5
N20 G0 X10  Y10
N30 G1 Z-1 F10
N40 G1 X10 Y20 F20
N50 G1 X20 Y20
N60 G1 X20 Y10
N70 G1 X10 Y10
N80 G0 Z5
N90 G54 X30 (Activate work offset with X shifted by 30)
N100 G0 X10  Y10
N110 G1 Z-1 F10
N120 G1 X10 Y20 F20
N130 G1 X20 Y20
N140 G1 X20 Y10
N150 G1 X10 Y10
N160 G0 Z5
N170 G53 (Cancel work offset)
N180 M30 (End program)

4.1.7 G70/G71 – Units of Measurement

· G70 sets the coordinate system to inches.
· G71 sets the coordinate system to millimeters.
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4.1.8 Drilling Cycles G73, G80–G84

This chapter describes the drilling cycles G81, G82, G83, and G84.

Change to G84
The G84 command has been modified.
If you need to use the legacy version, enable the option “Use old G84” in the menu: "Settings
→ Options → DIN66025 ."

G98 / G99 – Retract Height
· G98 – After the drilling cycle, the tool returns to the initial (start) height.
· G99 – After the drilling cycle, the tool retracts only to the R plane (retract height), defined by

parameter R.

G80 – Cancel Drilling Cycle
The drilling cycle is canceled with G80 or by issuing another motion command such as G00 or
G01

G81 / G82 – Simple Drilling and Drilling with Dwell
These cycles are used for basic drilling (G81) and drilling with dwell at the bottom of the hole
(G82).
Format: G98(G99) G81(G82) X Y Z R F (P)

Parameters for G81
· X – X position
· Y – Y position
· Z – Drilling depth (absolute)
· R – Incremental retract height, relative to the start point in Z
· F – Feed rate

Additional parameter for G82
· P – Dwell time at the hole bottom (in milliseconds, 1000 ms = 1 second)
Example:  G98 G82 X10 Y10 Z-10 F300 P100

G83 – Peck Drilling (Deep-Hole Drilling with Chip Breaking)
Compared to G82, G83 includes the additional parameter Q, which defines the depth of cut per
peck to break chips.

59



58 cncGraF 8 Online Hilfe

Copyright © 1993 - 2025 by BOENIGK-electronics

Abbildung 1: Entspänen mit Q Parameter

Format: G98(G99) G83 X Y Z R F P Q

Parameters for G83
· X – X position
· Y – Y position
· Z – Drilling depth (absolute)
· R – Incremental retract height, relative to the start point in Z
· F – Feed rate
· P – Dwell time at the hole bottom (in milliseconds)
· Q – Peck depth (in mm)

Example:  G98 G83 X10 Y10 Z-10 F300 P100 Q2

G73 – High-Speed Peck Drilling
This cycle is similar to G83, but instead of retracting completely after each peck, the tool only
performs a short retract motion. The retract distance can be configured under Options →
DIN66025.

G84 – Tapping Cycle (Right-Hand and Left-Hand Threads)
Format: G98(G99) G84 X Y Z R P F M

Parameters for G84
· X – X position
· Y – Y position
· Z – Thread depth (absolute)
· R – Incremental retract height, relative to the start point in Z
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· P – Dwell time at the hole bottom (in milliseconds)
· F – Feed rate (must match thread pitch)
· M – M03 for right-hand threads, M04 for left-hand threads

Example:  G98 G84 X10 Y10 Z-10 F300 P100 M03

4.1.9 Drilling Cycle G84 (Legacy Version)

In the legacy version of G84, drilling is performed with pecking (chip breaking). The tool drills
to the specified end depth Z at the programmed feed rate F, reaching the final depth step by step
through multiple incremental cuts.

Parameters for G84 (Legacy)
· X – X position
· Y – Y position
· Z – Final drilling depth
· D – Incremental step depth in Z

If omitted (D or D0), the tool drills directly to the final depth in one pass
· F – Feed rate
· H – Safety clearance (retract height)
· E – Dwell time at the bottom (in seconds)

Example
...
...
N110 G00 G90 M03
N120 G00 X10 Y10
N130 G00 Z3
N140 G84 Z-10 D5 H3 E2 F50 (Drill a hole with pecking steps)
N150 G84 X100 (Drill another hole at X=100, Y=10 using the same parameters)
...
...

4.1.10 G87 – Circular Pocket

The G87 command is used to machine a circular pocket. The coordinates X, Y define the
center of the pocket.

To achieve the desired pocket dimensions, the tool diameter D should be specified together
with the tool number (see example below, line N100). If no diameter is specified, the value is
taken from the tool library.
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The pocket is milled from the center outward in a clockwise direction at the specified feed
rate F and with the incremental step K. The depth is cut step by step, with each pass defined by
the incremental depth D and executed at the Z feed rate E. After the final depth is reached,
the machine retracts to the safety height H and the cycle ends.

Parameters for G87
· X – X position (pocket center)
· Y – Y position (pocket center)
· Z – Absolute final depth
· R – Pocket radius
· K – Radial step-over (X/Y direction)
· D – Depth increment (Z direction)
· F – Feed rate (X/Y direction)
· E – Feed rate in Z
· H – Safety clearance

Example
...
...
N100 T1 D1 M6 S500  ; Tool 1 with a diameter of 1 mm (D1) is selected 
N110 G00 G17 G90 M3
N120 G00 X50 Y50
N130 G00 Z3
N140 G87 Z-5 K1 D2 R4 F150 E50 H3
...
...

4.1.11 G90/G91 – Absolute or Incremental Programming

· G90 sets absolute programming, meaning all subsequent coordinates are specified relative to
the program’s absolute zero point.

· G91 sets incremental (relative) programming, where each new position is calculated
relative to the current tool position (chain dimensioning).

Example
N08 G90 (Set absolute programming) 
N09 G01 X100 Y100 (Move to absolute position X100 Y100) 
; Switch to incremental programming (chain dimensioning) with G91 
N10 G91
N11 G01 X10 (Move to X110 Y100)
N12 G01 X5 Y-5 (Move to X115 Y95)
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4.1.12 M99 – Subprograms

With M99, up to 99 subprograms can be defined at the end of the main program (after M30). A
subprogram definition begins with M99 P.. and ends with M99. The subprogram is called using
the command P.. within the main program.

 Note: The syntax for calling subprograms has changed compared to earlier versions.

Example 
N10 T1 M3 S2500
N20 G0 X21.5 Y25
N30 Z-5 M8
N40 G91
N50 P1 (Call subprogram 1)
N60 G90
N70 G0 Z0 M9
N80 X21.5 Y75
N90 Z-5 M8
N100 G91
N110 P1 (Call subprogram 1 again) 
N120 G90
N130 G0 Z0 M9
N140 M5
N150 M30 (End of main program)

N160 M99 P1 (Start definition of subprogram 1)
N170 G2 I3.5 J0 Z-2 F360
N180 I3.5 J0 Z-2
N190 I3.5 J0 Z-2
N200 I3.5 J0 Z-2
N210 I3.5 J0 Z-2
N220 I3.5 J0 Z-2
N230 I3.5 J0
N240 G1 X3
N250 G2 I0.5 J0 Z-2 F180
N260 I0.5 J0 Z-2
N270 I0.5 J0 Z-2
N280 I0.5 J0 Z-2
N290 G0 Z20
N300 M00
N310 M99 (End of subprogram)

Subprograms can be managed directly in the integrated text editor. Open the subprogram
manager via the menu: Edit → Subprograms in the text editor.
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4.1.13 M995 to M998 – Macro Execution

The control commands (M functions) M995 to M998 start a macro within a DIN66025
program file.

Example
N10 G90 (Set absolute programming)
N20 G01 X100 Y100 (Move to position X100 Y100)
N30 M995  (Start macro)  
M30

In the dialog Settings → Link Macro, the desired macro can be assigned to one of the
commands M995–M998. Macros can also be added directly into a DIN66025 file using the
integrated text editor.
For more information, see the chapter Integrated Text Editor .

4.1.14 M48 / M49 – Feedrate and Spindle Speed Override

M48 – Override Enabled
After calling M48, the operator can adjust the current override values for feedrate (F) and
spindle speed / cutting speed (S) using either a potentiometer or the keyboard.

M49 – Override Disabled
With M49, changes to the override values for feedrate (F) and spindle speed / cutting speed
(S) via potentiometer or keyboard are locked.

142
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4.1.15 R-Parameters

What is an R-Parameter?
An R-Parameter is a variable (R1 to R999) that stores a numeric value. Example:  R10 =
99.567 This defines R10 with the value 99.567. Calling R10 in the G-code retrieves that
value.

Using R-Parameters

Arithmetic Operations
Basic operations such as addition, subtraction, multiplication, and division are supported inside
an R-Parameter. Calculations follow the rule of operator precedence (multiplication/division
before addition/subtraction). Parentheses are not supported.

Example:
R56 = 10/2 - 2*2

Result: 1

Using Other R-Parameters in Calculations
R-Parameters can reference each other.

Example:
R55 = 10
R56 = R55/2 - 2*2

Result: 1

R-Parameters in G-Code
R-Parameters can be used in multiple G-code contexts:

· G00: G00 X=R10

· G01: G01 X=R10 Y=R11 + 6 / 2

· G02/G03 (arc commands): G02 I20 J20 X=R10 Y=R10

· G25 (loops): G25 Q=R4

· G53–G60 (work offsets): G54 X=R20

· IF statements: $IF R100==1

Global Scope
R-Parameters are global variables. Once defined in a G-code file, they are available throughout
the entire file.

Use in Subprograms
R-Parameters can also be used inside subprograms.

Status Display
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The values of all R-Parameters are displayed in the status bar of the text editor.

Example – Loop with Parameters
R4 = 4     ; R4 defines number of iterations  
R5 = 110   ; R5 defines X-position for the subprogram  

G25 Q=R4   ; Loop with 4 iterations  
P1         ; Call subprogram  
G00 X=R5   ; Move to position defined in R5  
G26        ; End loop  

4.1.16 IF Statement

What is an IF statement?
The IF statement is used to evaluate a condition. If the condition is true, the corresponding G-
code commands are executed. The following comparison operators are supported:
· Equal: (==)
· Not equal: (!=)
· Greater or equal: (>=)
· Less or equal: (<=)

An IF statement consists of the commands $IF, $ENDIF, $ELSE, and $ELSEIF. Each IF
statement must appear on its own line and can be used both in the main program and in
subprograms.

Syntax of the IF Statement
· $IF – defines the start of the condition
· $ENDIF – ends the condition
· $ELSE – executes alternative commands if the condition is not met
· $ELSEIF – checks an alternative condition

Examples
Example 1 – Simple IF statement
R57 = 10  ; Def ine parameter R57 with the value 10
$IF R57 == 10
; This G-code is executed because the condition R57 == 10 is true
$ENDIF

Example 2: IF-ELSEIF-Statement
R57 = 9
$IF R57 <= 9
 ; This G-code is executed because the condition R57 <= 9 is true
$ELSEIF R57 >= 10
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 ; This G-code is NOT executed because R57 = 9
 ; If R57 were 10 or greater, this block would be executed
$ENDIF

Important Notes
· Nested IF statements are not allowed

 An IF statement must not be placed inside another IF statement. Doing so will result in an
error.

Incorrect:
$IF R200 == 0
  ; G-Code
  $IF R1 == 1
    ; G-Code
  $ENDIF
$ENDIF

Correct:
$IF R200 == 0 
 ; G-Code 
$ENDIF 

$IF R1 == 1 
 ; G-Code 
$ENDIF
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4.2 DXF

The DXF format (Drawing Exchange Format) was developed by Autodesk for AutoCAD and is
used for data exchange between CAD programs. cncGraF 8 currently supports the following
DXF entities:

· 3DFACE
· ARC
· CIRCLE
· LINE
· LWPOLYLINE
· POINT
· POLYLINE
· SPLINE
· VERTEX
· LAYER
· ELLIPSE

 Since 3D DXF files are not suitable for milling, they are imported as 2D files. The Z-
depths are taken from the tool library.

Layers
The cncGraF 8 software can automatically assign the data of a layer to a tool. For this to work,
the name of the layer must be specified in the tool library in the tool’s Name field. In addition,
after opening a DXF file, the DXF Layer dialog will appear, allowing you to manually assign
layers to any tool.

4.3 HPGL

Hewlett-Packard Graphics Language (HPGL) is generated or exported by many CAD
programs. cncGraF 8 supports the following HPGL commands:

Supported HPGL Functions
· PU – Pen Up (lift tool)
· PD – Pen Down (lower tool)
· PA – Absolute Positioning
· PR – Relative Positioning
· SPx – Select Pen / Tool number
· AA – Absolute Arc
· AR – Relative Arc
· CI – Circle
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Example

HPGL Description

 
PU;
PA100, 50;
PR100, 50;

PD;
CI100;

AA300, 200, 50;

SP1;

 
Lift tool
Move to absolute position X=100, Y=50
Move to relative position (new absolute position: X=200, Y=100)
Lower tool
Draw a circle with radius 100, counterclockwise (negative radius
→ clockwise)
Draw a 50° arc with center at X=300, Y=200, starting from
position X=100, Y=50

Select tool number 1

4.4 GRF5

The GRF5 Interpreter is a cncGraF 8 file format that stores the following
information:

· Vectors and drilling points (all drawing elements)

· Tool library for vectors and drilling points

· Tool compensation (radius compensation)

· Units and scaling

· Material offset and workpiece zero point

· Tool processing sequences with depth-of-cut compensation

· File properties

When opening GRF5 files, cncGraF 8 checks whether the workpiece zero
point saved in the GRF5 format is active. If the zero point is not found, a
message is displayed prompting the user to verify the workpiece offset.

4.5 Postscript and Adobe Illustrator

cncGraF 8 can load Postscript 3 files (.eps)  and Adobe Illustrator f iles (.ai).
Postscript is a page description language developed by Adobe. The Adobe Illustrator format is
based on Postscript but provides a more limited command set.
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  Use Postscript or Adobe Illustrator files to import data (e.g., from CorelDRAW). To
ensure that text objects from CorelDRAW are imported correctly, the option “Export text as
curves” must be enabled.

4.6 Drill Data

cncGraF 8 can read drill data in Excellon, Sieb & Maier 1000, and Sieb & Maier 3000
formats. Below are two examples in the Sieb & Maier format:

Sieb & Maier Description

Example 1 Example 2

%
T01
X001Y0001

M30

%
T01
X100Y10

M30

T01 selects Tool 1. Position X=100,
Y=10 is reached and drilled into the
material. The program ends with
M30.
Same operation, written in the second
format.

Two Types of Drill Files

1. First Format (with leading zeros)
Coordinates use a 5-digit notation, but trailing zeros are often omitted.
· Example: X001 actually means X00100, and Y0001 means Y00010.

2. Second Format (without leading zeros)
Coordinates are written without leading zeros after the axis letter, which results in values of
different lengths.

Although the formats look different, both describe the same machine setting. In the Options
dialog, you can switch between the two formats.

5 Settings

This section describes all relevant settings required for operating the machine.The Settings main
menu provides the following functions:

· Positions : Defines zero points, parking positions, and measuring points used during
machining.
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· Workpiece Parameters and Workpiece Offset : Specifies the material and displays it in
the 2D view.

· Tool Library: Used to define tools, including feed rates, Z-depths, stepdowns, and other
parameters for 2D files.

· Safety Zones: Provides software-based monitoring of the CNC machine’s position.
· Options: Includes various interface customization settings. File-related options can also be

configured here.
· Input Devices: Settings for handwheel, Xbox controller, keyboard, control panel, etc.
· Macro Editor and Macro Linking: Extends functionality by allowing macros to be created

and linked. Linked macros can be triggered automatically at different stages of the process.
· Plugin Manager: Enables cncGraF 8 to be extended with external software.
· Units and Scaling: Defines the measurement units and scaling factors.
· Zero Point Tools: Provides multiple methods for defining the workpiece zero point.
· Link Settings: Allows different configurations to be linked. A shortcut is created on the

Windows desktop that starts cncGraF 8 with the selected configuration.
· Video Positioning: Aligns the drawing with fiducial marks, ensuring it matches the actual

material position on the machine.

74
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5.1 Positions

Before a parking position, zero point, or measuring position can be approached, it must first be
created in the Edit Positions dialog. This dialog can be accessed from the main menu via
Settings → Positions.

 Any number of zero points, parking positions, or measuring positions can be created, but
only one of each type can be active at a time. Therefore, at most one zero point, one parking
position, and one measuring position will be displayed graphically.

Add Position
Clicking the Add button opens the Add Position dialog. Here, you can enter the parameters of
the point (X, Y, Z, A, B coordinates, status, and name). The Z-height can also be defined by
entering the material thickness. To use this option, the tool length sensor must be calibrated once.
(For more details on the two types of zero points, see Settings → Positions → Zero Points.)

Editing Properties of Zero, Parking, and Measuring Points
Under Properties, you can specify how points are approached—either directly or in a chosen
axis order. The option Show confirmation dialog enables or disables a dialog box before
movement begins. You can also choose whether the machine should automatically move to the
zero point after homing. The value entered in the Z Safety Distance field defines how far the
axis retracts upward after zero point probing.

Measuring Point: Multiple Measurements
This option allows measurements to be repeated, such as recording tool lengths or probing edges
with a 3D sensor. By averaging multiple measurements, higher accuracy can be achieved.
Additionally, error detection is included: if a measured value deviates too much, the software
automatically issues an error message and aborts the process.
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Machine Position
The current position of the CNC machine can be saved by clicking Machine Position → Set
(see figure below).

Enable or Disable Calibration
Here  you can switch between two types of zero points: a simple XYZ zero point or a zero
point that also includes tool length and workpiece height. For more details on these two zero
point types, please refer to the corresponding section.
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5.1.1 Zero Points

There are two types of zero points:

1. Simple Zero Points (without tool length and workpiece height)
These zero points can only be used when calibration is disabled or not available. They do not
include Z-correction and are suitable for simple jobs where only one tool is used.

2. Zero Points with Tool Length and Workpiece Height
These zero points are measured when created and include both tool length and workpiece height
data. For this, the tool length sensor must be calibrated once. If the tool length sensor is not
calibrated, the Calibration switch is inactive, and zero points with tool length are not available.

Zero points with tool length can be used for files with multiple tools.
· For manual tool changes, a parking position must be defined.
· For automatic tool changers, a parking position is not required as long as the tool to be

changed is within the tool changer.

Advantages of zero points with measured tool length:
· If a tool is changed but the workpiece height remains the same, the Z-height of the zero point

does not need to be manually reset. The length of the new tool is compared with the old tool,
and the Z-height of the zero point is automatically adjusted.

· If the workpiece height changes but the tool length remains the same, the Z-height does not
need to be manually redefined. The new workpiece height can be entered directly in the table.
cncGraF 8 then calculates the new Z-height and updates the zero point accordingly.

Disadvantages of zero points with measured tool length:
· At the beginning, the zero point must always be set manually, since tool length and workpiece

height are initially unknown. For automatic Z-height determination of the zero point, a 3D
probe is recommended.

Z Safety Distance
Once the new Z-height for the current zero point is defined, a relative move upward from the
zero point can be executed. This move is called the Z safety distance.
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5.1.2 Measuring Points

Multiple measuring points can be managed in the Positions dialog, but—similar to zero points
and parking positions—only one measuring point can be active at a time.

 Important: A measuring point consists of the three coordinates (X, Y, Z) plus the
maximum tool length. The machine first moves to the defined X, Y, Z position and the
maximum tool length before the actual measuring process begins.

Critical Note: The measuring point Z + maximum tool length must be defined high enough
to ensure that the longest tool fits between the starting Z-height (measurement start) and the tool
length sensor.

Z-Safety Height After Tool Measurement

After the tool length has been measured, the machine automatically moves to a Z safety height:
· With automatic tool changer:
The values Z position of  the f irst tool, Zero Point Z, and Measuring Point Z are compared.
The highest Z-value plus the flight height is approached.
· Without automatic tool changer:
The values Zero Point Z and Measuring Point Z are compared. The highest Z-value plus the
flight height is approached.

 Collision Warning: If the zero point is set on the underside of the material, the tool may
collide with the material when moving to the measuring point due to material thickness or a low Z
measuring position. To avoid collisions, enable the option "Move to Z-axis maximum before
moving to measuring point" under Settings → Positions → Measuring Point.
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5.2 Workpiece Parameters and Workpiece Offset

Workpiece Parameters
For visual verification, the size and position of the workpiece can be displayed graphically. The
workpiece, accessible via Settings → Workpiece Parameters, can be aligned either with its
lower-left corner or centered at the zero point. The defined workpiece dimensions in the X and
Y directions are displayed in the selected color.

Workpiece Offset
The workpiece offset is the distance between the marked workpiece holder and the workpiece
zero point (see figure). In the GRF format, both the workpiece offset and the workpiece zero
point are stored. The workpiece zero point stored in the GRF file is only used for validation
when opening the GRF file. If the zero point of the loaded drawing does not match the active
workpiece zero point, the following message appears:

cncGraF 8 does not contain the drawing’s workpiece zero point!  Please check the workpiece
offset.
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 If the workpiece zero point has changed, it is not necessary to update all GRF files. It is
sufficient to adjust the value of the workpiece offset in the currently opened GRF file.

5.3 Change Tool Number

The tool numbers of a loaded file can be adjusted in two ways:

Directly in the drawing:
· Using a selection box and the tool palette → Tools → Tool Properties (only available for 2D

files).

Via the dialog:
· From the main menu, go to Settings → Change Tool Number to adjust tool numbers.
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5.4 Tool Library

The Tool Library dialog (menu: Settings → Tool Library) manages two tool lists:
· Vectors: For DXF, HPGL, and optionally G-Code (DIN66025, see Settings → Options →

File → G-Code).
· Drill Points: Only for Sieb & Maier file types.

At the top of the Tool Library window, you can enter the tool library name (e.g., [My Tool
Library] ). Clicking the icon with three horizontal lines on the right side of the window opens the
tool library management menu.

Global Settings

Use Spindle Speed
The spindle speed can be controlled in 255 steps. First, enable the Use Spindle Speed option.
By clicking the Set Sp indle Speed icon, you can define the ranges for these steps. If the DAC-
INT-10V v.02 interface is used, make sure the corresponding field is activated.

Use Tool Lengths from the Tool Library
This function reduces the number of required measuring operations.

Collet Offset
If a value is specified here, it will be subtracted from the tool length in the Positions dialog. In
Positions → Zero Points, the actual workpiece height is then displayed. This parameter has no
functional effect; it is only used for visual representation.

Use Body Length from the Tool Library
When enabled, each tool is assigned an individual Z-height via the probe. If a tool does not have
a body length specified under the Tool Properties tab (body length = 0), the longest body length
from Positions → Measuring Point will be used instead.

Tool Properties

Tool Type, Diameter, and Body Length
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In the Tool section, you can enter the tool type, diameter, and body length. The diameter is used
for calculating tool compensation in the Tool Compensation dialog. The body length is activated
in the Global Settings section. Information such as the tool type and other parameters are
required for generating 3D models.

Feed Rates, Cutting Depth (Z), and Spindle Speed
Operating parameters such as feed rate, cutting depth, and spindle speed can be assigned here.
In the Active column of the table, tools can be enabled or disabled. Polylines assigned to inactive
tools appear gray in the drawing and are not used for machining.

Cutting Depth (Z)
Since 2D files such as DXF or HPGL do not include Z-depth information, the cutting depth (Z)
must be manually entered in the tool properties for each tool. The total cutting depth is composed
of:
· Cutting depth (Z)
· Z-offset
· Repetitions
· Incremental depth correction

Example
A tool first plunges 3 mm into the material. The operation is then repeated twice (Repetitions),
each time with an additional 1 mm depth. This results in a total cutting depth of 5 mm. The Z-
offset shifts the Z-axis by the specified value (similar to the X/Y offset).

Switching Outputs
Each tool can be assigned outputs to switch external devices on or off.

Speeds
Since 2D files (DXF, HPGL) do not contain speed parameters, speeds must be entered
manually for each tool.

 For G-code files (DIN66025), the speeds defined in the tool library can also be used. To
enable this, activate the option “Use Speeds from Vector Tool Library” in the dialog Settings
→ Options → File → G-Code.
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Tool Extras

Z2
Allows a tool to be redirected to the second Z-axis. For this, the X/Y offset of the Z2 axis must
be specified. This function is only used for 2D files such as HPGL or DXF. For DIN66025, the
data for the fourth axis (Z2) must already be included in the file.

Tangential
Allows a tool to be assigned to the A- or B-axis as a tangential axis.
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5.5 Safety Zones

A safety zone (Menu: Settings → Saf ety Zones) protects against unauthorized actions. Any
number of safety zones can be defined. A good example of applying a safety zone is the
automatic tool changer. Within the tool changer’s area, only tool changes hould be carried out.
All other actions, such as Manual Move or Jogging/Move To, are dangerous for the automatic
tool changer.

The figure on the left shows a tool changer (4 tools) protected by the Saf ety
Zones function.

A safety zone is displayed as a gray rectangle with a diagonal line.

The following actions can be permitted within safety zones:
· Manual Move
· Milling/Drilling
· Tool Change
· Tool Measurement
· Move to Position

 Important: Safety zones are a purely software-based solution and cannot guarantee
sufficient protection if cncGraF 8 does not know the exact position of the CNC machine.

5.6 Options

The Options dialog (Menu: Settings → Options) contains all program settings, organized into
different sections.

File → Properties
In the File section (Menu item File), you can configure settings related to loading files. For
example, under File Properties you can specify whether a file should automatically be aligned to
the zero point after opening.

The lower section contains options that apply exclusively to 2D files such as DXF or HPGL (not
to DIN 66025 files).
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In certain cases, it is useful for the tool not to begin machining immediately after
plunging into the material, but instead to pause for an adjustable time.
For this, a dwell time af ter tool down can be defined in milliseconds. If the tool should also
remain briefly in the material before lifting, an additional dwell time bef ore tool up  (in
milliseconds) can be set.

Furthermore, a sp indle startup  delay (in milliseconds) can be configured to ensure that the
spindle reaches its full speed before the machining process begins.

Activate pump only after the “PD” command (Plasma/Laser)
The pump output (Machine Parameters -> Pin Assignment ) can be used for plasma or laser
units. Activation only occurs after the HPGL command PD (lower Z-axis). This feature is
especially important for plasma cutting, as the arc remains stable only at the correct distance from
the material.

Additional file-related options for G-Code (DIN 66025) are explained in the chapters G-
Code Settings  as well as DXF, HPGL, PostScript, Sieb & Mayer, SVG .

Options – Overview

The Options dialog offers several tabs that allow you to customize the software interface and
operation to your needs. The following areas are available:

General & Tool Palette
· Set software appearance (theme, colors)
· Define working directory
· Invert zoom direction in 2D view
· Show or hide functions in the tool palette

Colors & Grid
· Set colors for 2D view elements (e.g., color of rapid-move vectors)
· Configure the grid
· Define line thickness of tool compensation lines (in pixels)
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Fonts, Icons & Touchscreen
· Select font and size for menus
· Adjust icon size (important for high-resolution displays)
· Customize the color of absolute and relative coordinates

3D
· Define settings for the 3D view
· Enable/disable display of the machine area and the workpiece
· Adjust color transparency with sliders

Messages
In this section, messages can be defined that appear during certain actions.
Conditions are checked and—if met—a message is displayed for the operator.

Typical use cases include safety messages such as:
· “Check drawing position bef ore milling”
· “Warning: Open collet?”
· “Warning: Sp indle on?”
· “Tool length successf ully measured.”
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5.6.1 G-Code Settings

For G-Code files (DIN 66025), feed rates specified with the command “F” are always given in
millimeters per minute. Since cncGraF 8 internally works with speeds in millimeters per
second, an automatic conversion is performed.
Feed rates can also be scaled by a factor or taken directly from the tool library.

· Factor: Multiplies the feed rates defined in the file. A value of 1 leaves the feed rates
unchanged.

· To use the feed rates from the G-Code file, the option “Use feed rates from vectors tool
library” must be disabled.

 Display of Feed Rates: The feed rates from the G-Code file (if available) are only displayed
in the table after the file has been loaded.

DIN 66025 – Configuration Options
· Command G02/G03 (Circular interpolation, clockwise/counterclockwise):

Can be interpreted either relative or absolute.

 Note: An incorrect setting may result in misinterpretation of the arc.

· Z-Vector Inversion: Reverses the direction of the Z-axis.
· Drill Spindle Startup Time (ms): When starting, the machine switches on the spindle and

waits for the specified time until the rated speed is reached.

 This option is only required if the G-code file does not contain a G04 H command.

M20/M21 (Plasma Torch)
For command M21, a startup delay (ms) can be defined.
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Drill Points
Display drill points as crosses.

Decimal Places
Defines how many decimal places are used when loading the file.

Legacy G84 Version
Enable this option to ensure compatibility with older cncGraF 8 versions.

Axis Definition
Assign custom letters for the axes.

Lift Distance for G73
Defines the short retraction distance after each peck during G73 drilling.

Arc Resolution (G02/G03)
The G-code commands G02/G03 (circular interpolation) are converted into vectors when
loaded.
This is necessary because controllers work vector-based (Step/Dir).

Since CNC machines have a defined axis resolution (set under Machine Parameters → Axes
→ Steps per Revolution and Travel per Revolution), the chosen drawing resolution should not
be lower than the machine resolution.
You can visually check the arc resolution in the 2D view by enabling: View → Start and End
Points of  Vectors.

The arc resolution: medium or high is recommended, as it provides a good balance between
accuracy and data size.

M-Commands
In the Outputs tab (M-commands), commands can be defined to switch outputs on or off.
With M04, the spindle rotation direction is set to counterclockwise. The corresponding output
for counterclockwise rotation must be specified.

Since cncGraF 8 can control up to 3 analog channels (AD0 to AD3), these can also be
switched via M-commands.

Example for switching an output:
For output 10, the commands M70 (on) and M71 (off) are defined.
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If M70 appears in the G-code, output 10 is switched on.
With M71, the same output is switched off again.

In copied drawing elements
This section defines how a G-code file should be copied.

 Note: Keep in mind that a G-code file already represents a complete 3D description file
for the CNC machine and normally should not be modified.
Furthermore, G-code files are generally difficult to edit manually. cncGraF 8, however, offers the
option to copy G-code files upon customer request.

To ensure this process runs as smoothly as possible, several options are available:

1. Remove specific commands, e.g.:
· G04 (dwell time)
· M05 (spindle off)
2. Automatically insert a G00 Z… command (initial height, value defined in the input field).

Message if command not found
With this option, a user message can be defined that automatically appears when opening a G-
code file if a specific G-code command (character) is not found.
The command to check is entered in the input field “Command.”
The desired message is entered in the input field below.
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5.6.2 DXF, HPGL, PostScript, Sieb & Mayer, SVG

All of these file formats use the same import dialog. In this dialog, the following settings can be
configured:
· Arc resolution: Defines how finely circles and arcs are divided into line segments. Medium or

High is recommended, as this provides a good balance between accuracy and data volume.
· Unit: Defines the unit of measurement for the coordinates.

 DXF files are usually created in millimeters. Therefore, unit 1 (mm) is typically used.

5.7 Input Devices

The following components can be used as input devices (Menu: “Settings → Input Devices”):
· Keyboard (Keypad)  
· External Control Panel
· Microsoft Xbox Gamepad
· Handwheel
· Industrial-Joystick  (no longer supported)

The settings for the keyboard, external control panel, and Xbox gamepad are configured in the
menu “Settings → Input Devices”. The available functions are grouped into the categories:
Manual Move, Move, Switch Relays On/Off, Other Functions, and Macro .

Figure: Setup menu for keypad, external control panel, and Xbox gamepad

5.7.1 Keyboard

In the dialog “Configure Keyboard, External Control Panel, and Xbox Gamepad” (Menu:
“Settings → Input Devices”), the keyboard can be enabled, and specific functions can be
assigned to the keys of the PC keyboard or an external keypad.
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 Important: Since the assigned functions are executed immediately, it is strongly
recommended to configure the key mapping carefully..

The keyboard can be enabled or disabled using a switch. To change the assignment, click on the
desired cell in the list and then assign a key.

 The keyboard is not permanently active. In certain dialogs, such as the text editor or
manual move mode, the keys are automatically disabled to prevent unintended functions from
being triggered. The keys are only active when the corresponding symbol in the status bar is
displayed in blue.

5.7.2 External Control Panel

An external control panel can also be used to operate the machine. This is a simplified, wired
remote control that is typically connected via the Con2 interface. Each switch or button on the
panel is assigned to a pin (input) of the interface.

The control panel can be configured in the menu: “Settings → Input Devices → Keyboard,
External Control Panel, and Xbox Gamepad.” In the “External Control Panel” column of
the table, each pin (= button/switch) can be assigned a specific function.
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 Note: When using an external control panel, the signals are transmitted to the controller via
switching relays. This can lead to unwanted input activation caused by interference pulses. To
prevent this, the number of queries until the switching process is confirmed can be adjusted.

Figure: The query must last at least 100 ms before a relay is recognized as switched.

5.7.3 Xbox Gamepad

The software cncGraF 8 also supports using a Microsoft Xbox Gamepad to control the machine.
This feature can be enabled or disabled via the menu:
Settings → Input Devices → Keyboard, External Control Panel, and Xbox Gamepad.

Within the dialog, the buttons and joysticks of the gamepad can be assigned to functions such as:
· Switching manual speeds
· Homing cycle (Reference move)
· Moving to the zero point
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· And other operations

If the value “-1” is entered for a button, the assigned function is disabled.
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5.7.4 Handwheel

With cncGraF 8, the machine can also be controlled via a handwheel (menu:
Settings → Input Devices → Handwheel). This option provides a convenient way of manual
operation and can be enabled or disabled in the menu. Control buttons can be assigned to
specific functions.

In the fields “0.1” or “0.01”, the size of the incremental step is defined in millimeters.
· Turning the knob by one detent moves the machine by the selected step.
· Turning by two detents moves it by two steps, and so on.

This allows precise positioning and comfortable visual control when approaching the target
position. The minimum selectable step size is limited by the machine’s resolution.

Rapid Move
By turning the handwheel while simultaneously pressing one of the “–” or “+” keys, the machine
moves left or right. The travel speed is controlled by the handwheel knob. Releasing the “–” or
“+” button stops the machine automatically.

Special Functions (requires firmware 0.26 or higher)

The handwheel supports additional functions that can be triggered with key combinations:
· F2 + F3 (Direction change in rapid move mode): Change travel direction directly with the

handwheel, without using the “+/–” keys.
· F10 + F11 (Change travel direction for X/Y): Select an axis (X or Y) and switch the travel

direction.
· F6 + F7 (Buzzer on/off): Enable or disable the acoustic signal.
· F3 + F4 (Encoder/Potentiometer selection): Switch between encoder and potentiometer.

This setting depends on the hardware of the handwheel and should only be modified if
required.

Sonderfunktionen des Handrads (benötigt Firmware 0.26 oder höher)
Das Handrad unterstützt zusätzliche Funktionen, die über Tastenkombinationen aufgerufen
werden können:
· F2 + F3 (Richtungswechsel im Rapid-Move-Modus): Fahrtrichtung direkt mit dem Drehrad

ändern, ohne die Tasten „+/–“ zu verwenden.
· F10 + F11 (Fahrtrichtung ändern für X/Y): Auswahl einer Achse (X oder Y) und Wechsel der

Fahrtrichtung.
· F6 + F7 (Buzzer Ein/Aus): Akustisches Signal ein- oder ausschalten.
· F3 + F4 (Encoder/Potentiometer-Auswahl): Umschalten zwischen Encoder und

Potentiometer. Diese Einstellung ist abhängig von der Handrad-Hardware und sollte nur bei
Bedarf verändert werden.

 The respective keys must be held for about 2 seconds to activate or change the function.
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Settings Overview

1. Emergency Stop (NOT-AUS): Immediately halts the machine and cuts off the power supply
to the electronics.

 Warning: For the electronics to be fully disconnected from the power supply, the terminals
must be connected at NA2 (see wiring diagram).
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 Safety Notice: If the connection is not made according to the wiring diagram, pressing the
emergency stop button will not cut the power supply — it will only interrupt the program.

2. Axis Selection Keys: The last selected axis is stored.
3. Travel of All 5 Axes: Controlled via the rotary wheel (optical encoder).
4. Single-Step Motion Keys.
5. Rapid Move Keys: To enable rapid moves with the wheel, the “–” or “+” key must be
pressed simultaneously.
6. Feedrate Adjustment in Percent: From 1% to 100%.
7. Function Confirmation Key.
8. Function Keys:
· Perform homing cycle
· Move to zero point
· Move to park position
· Spindle on/off
· Set X/Y/Z zero point
· Pump on/off
· Start job 
· Resume job
· Pause 
· Abort
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9. Spindle Speed Adjustment with Handwheel: The spindle speed can be changed during
machining. To adjust it, the B axis (see point 2) must be selected, and the wheel (see point 3)
turned.
10. Freely Programmable Function Keys (F1–F12): These keys can be custom-labeled.

11. LED Status: When the emergency stop is pressed, all LEDs light up (from handwheel
firmware V1.01).
12. Buzzer Control: Pressing F6 + F7 simultaneously toggles the handwheel buzzer on or off.

Dialog Window – Control

Many dialog windows can also be operated directly using the handwheel keys OK, Pause, and
ESC.
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5.7.5 Industrial Joystick (discontinued)

The electronic joystick is connected directly to the smc5d controller via cable. Since the machine
movement is controlled directly by the controller, there are no delays in CNC positioning. The
joystick includes three freely programmable buttons, which can be assigned in the input fields
“Buttons F1–F3”. It can be activated or deactivated in the menu Settings → Input Devices
→ Industrial Joystick.

Rapid Movement

Quick motion is achieved by pressing the X/Y or Z axis selection button along with the fire
button. The movement speed is controlled by the joystick’s orientation.

Settings Overview

1. Emergency Stop (NOT-AUS): Immediately halts the machine and cuts off the power supply
to the electronics.

 Warning: For the electronics to be fully disconnected from the power supply, the
terminals must be connected at NA2 (see Figure 1).

 Safety Notice: If the connection is not made according to the wiring diagram, pressing the
emergency stop button will not cut the power supply — it will only interrupt the program.

Figure 1: NA2 wiring diagram
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2. By pressing the X/Y or Z button together with the fire button, the XYZ axes can be moved via
the analog joystick. The movement speed is controlled by the joystick’s orientation. Maximum
permissible speeds can be set separately for the X/Y and Z axes.

3. Three freely programmable buttons can be assigned. By pressing F1–F3 together with the
OK button, the defined function is executed.

4. Joystick calibration: To calibrate, hold the X–Y and Z buttons for about 10 seconds until a
confirmation tone sounds.

5. Diagonal movement sensitivity can be adjusted with sliders. If desired, both diagonal travel
and the fire button function can be disabled.
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5.8 Commands

The “Commands” function provides a simple alternative to the Macro Editor. It allows
uncomplicated work sequences to be defined, which can be executed at any point during a
machining process. 

The linking of work sequences is done in the dialog “Link Macro/Command…” (main menu:
Settings → Macro/Link Macro…).

5.9 Macro Editor

The creation and use of macros in cncGraF 8 is an important tool for extending the software with
custom functions. For example, a macro can be developed to control a special tool changer, or
to operate machines with automatic tool clamps that must be opened or closed. This makes it
possible to implement numerous special functions that are not part of the original program but can
be added via macros.

Create or open a macro file
To create or open a macro file, start the Macro Editor from the main menu via Settings →
Macro Editor.... The following window will then appear:

Figure 1: Macro Editor with an opened macro file

Create your own macro
A custom macro (=program) can be written in the File tab .... Basic knowledge of C#
programming is required. To assist with coding, the text editor provides autocompletion,
automatic error detection, and syntax highlighting. Autocompletion displays a dropdown
function list during typing, making macro creation much easier.
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Figure 2: Autocompletion window after typing the dot (“.”).

Open an existing macro
Alternatively, an already existing macro can be opened. To do this, go to the Macro menu,
select Open..., and choose the desired macro file.

Test a macro
Before a macro is integrated into a machining job, it should first be tested. The test can be started
in the Macro Editor dialog using the Execute Macro button. The commands will then be
processed line by line and checked for logic.
If the syntax is error-free, the message “Execution succeeded” will be displayed at the end of
the test.
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Integrating Macros/Commands into a Job
Macros or commands can be assigned to a job via the dialog Macro/Command Link... (Menu:
Settings → Macro/Command Link...).

Examples of possible links:
· Job Start / Job End
· After machining
· Homing start/end (macro replaces standard functions)
· Pick up/return tool (replaces commands from machine parameters)

Assigning macros as buttons in Manual Move

Macros can also be linked to so-called free buttons. These are available as possible links in the
dialog Macro/Command Link....
Free buttons can be added to the Manual Move window via the context menu Customize
layout using drag & drop (plug-and-play). More details can be found in the chapter
Customizing Manual Move .

 Important: When macros are linked to the functions listed above, certain standard
functions (previously defined in the machine parameters, e.g. return tool) will be replaced by the
macro commands. In this case, the macros take priority.

125
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5.9.1 Macro Programming

This section explains the basics of macro programming. Every macro must start with the
following line:

// Create the macro (this line must always be at the beginning)
Macro theMacro = new Macro(this.Context.Parent, "Name of the macro shown
in the status bar during execution");

The line above creates a macro object named theMacro. The parameter
this.Context.Parent links the macro to cncGraF 8 and must always be provided. The
second parameter is the text that appears in the program’s status bar while the macro is running. 

Using the theMacro object, you can call various functions. The following macro executes DIN
66025 (G-code) commands. Commands are added line by line with
theMacro.AddNxx("...").
theMacro.Start(); executes all previously added commands.
theMacro.Clear(); clears the command list.

// Create the macro (this line must always be at the beginning)
Macro theMacro = new Macro(this.Context.Parent, "DIN66025 Befehle
ausführen");

// Add DIN66025 commands line by line
theMacro.AddNxx("G90");
theMacro.AddNxx("G0 Z1 M03");
theMacro.AddNxx("G0 X50 Y150");
theMacro.AddNxx("G0 Z5 M05");

theMacro.Start(); // Execute the DIN66025 commands

You can switch outputs or query their status from a macro. The macro below turns Output 1 on
and then checks its status.

// Create the macro (this line must always be at the beginning)
Macro theMacro = new Macro(this.Context.Parent, "Execute DIN66025
commands");

// Turn Output 1 ON ('true'); use 'false' to switch outputs OFF
theMacro.SetOutput(1, true);

// Query the status of Output 1
if(theMacro.IsOutputOn(1)) { 

// Output 1 is ON!
 theMacro.MessageBox("Output 1 is ON!");
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} else {

// Output 1 is NOT ON!
 theMacro.MessageBox("Output 1 is NOT on!");
}

Just like outputs, you can also query inputs. The macro below checks Input 9:

// Create the macro (this line must always be at the beginning)
Macro theMacro = new Macro(this.Context.Parent); 

// Query the status of Input 9. With 'true' or 'false' you can invert
the test.
if(theMacro.IsInputOn(9, true)) { 

// The IF statement evaluated to true (1),

// meaning Input 9 is ON.
 theMacro.MessageBox("Input 9 on Con3 is ON!");
}

With a macro, you can return and fetch tools. (Requires a connected tool changer.)

// Create the macro (this line must always be at the beginning)
Macro theMacro = new Macro(this.Context.Parent, "Return last tool and
fetch Tool 1");

theMacro.ToolPutOff();
theMacro.ToolFetch(1);

The macro below reads the machine’s absolute coordinates and shows them in a dialog:

// Create the macro (this line must always be at the beginning)
Macro theMacro = new Macro(this.Context.Parent);

var theZ = theMacro.GetAbsPosZ(); // Read machine position in Z

//  Show it in a dialog window
theMacro.MessageBox("Position der Maschine in Z beträgt: " + theZ);

This macro performs a homing cycle:

// Create the macro (this line must always be at the beginning)
Macro theMacro = new Macro(this.Context.Parent);
theMacro.Reference();
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Documentation for the Macro object can be found in the file macro.chm. This file is located in
the cncGraF 8 directory and can be opened from the Macro Editor.

5.10 Plugin Manager

A plugin is a program that attaches to a host application—here, cncGraF 8—to extend it with
new features. In the Plugin Manager dialog, plugins can be enabled or disabled. Once a plugin
is enabled, it appears under the main menu Plugins.

For more information on developing your own plugins (Visual Studio C# sample projects,
documentation), see: ...\Users\[BENUTZERNAME]\AppData\Roaming\cncGraF8\code\csharp

5.11 Unit and Scaling

Without the correct drawing unit, the dimensions of a drawing will not match the intended size.
To simplify the selection, several predefined units are available: 1 mil, 1/40 mm, 1/100 mm, and
1/1000 mm. If none of these presets are suitable, a custom unit can be defined in the input field.

 For the file type G-Code (DIN66025), specifying a unit is not possible because the file
always uses its original size. In this case, the Scaling dialog appears without a unit selection.

5.12 Tools for Zero Point Determination

To determine the zero point in X/Y, either a camera or a cross laser can be used. This function
can be enabled via the menu:
Settings → Zero Point Determination.

When the corresponding icons are pressed, the zero points in X/Y are automatically adjusted,
taking into account the preset offset between the tool (cutter) and the camera or laser.

           

The icons “Set Zero Point with Laser/Camera Offset” can be shown or hidden in the
standard toolbar. This is done using the arrow at the end of the toolbar.

5.13 Link Settings

To avoid constantly switching between configurations, a setting can be copied via the menu:
Settings → System Settings → Link and placed as a shortcut on the desktop.

When linking, a copy of the configuration is created and associated with the desktop shortcut.
This allows cncGraF 8 to be started with different configurations.
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5.14 Video Positioning

Before the video positioning system in cncGraF 8 can be used, it must first be set up for the
machine. The Video Positioning chapter is structured as follows:

1. Creating a calibration template with Corel Draw
2. Calibrating the video positioning system
3. Creating data for printing and cutting/milling with Corel Draw
4. Using video positioning

5.14.1 Creating a Calibration Template with Corel Draw

Start Corel Draw with a blank DIN A4 page.

Using the Circle/Ellipse tool, draw a circle with a diameter of 10 mm.
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Draw two lines crossing at the center of the circle. Use the Snap to Objects (Alt + Z) option to
align the lines from quadrant to quadrant.
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Select all three elements and group them together. Then assign line attributes. The line
thickness should be about 0.5 mm.
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Duplicate this marker once in the X-direction and once in the Y-direction.

The finished template should look approximately like this (see example illustration).
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Finally, save the file as a calibration template.

 Note: The spacing and size of the markers can be adjusted to personal requirements. The
sizes provided above are suitable for a camera distance of 120 mm and have proven effective in
practice.

5.14.2 Calibration of the Video Positioning System

Before the video positioning system can be used, it must first be calibrated. Proceed as follows:

1. Start the calibration dialog via Settings > Calibration of the Video Positioning System.
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Abbildung: Kalibrierungsdialog

2. In the interface, select the camera to be used.

3. Print a sheet with three marker points placed at equal distances (a template is included in the
program directory). Position the sheet under the camera so that all three points are visible in
the center of the display window.

4. Under Marker Type, select the shape of the marker. In the example shown, the marker type
is Circle + Line (more precise). The Radius parameter defines the circle size. The alternative
option is three solid black dots.

5. Enter the distance between the markers into the field Marker Distance → Obj ect
Distance.

6. Enter the values for the camera position (distance between the camera and the cutter in X
and Y).

7. Position the camera by manually moving the Z-axis until a sharp image is visible (the camera
does not support auto-focus). Transfer the Z-distance to the material into the field Z Position.

 Important: If the material thickness changes, the Z Position value must also be updated;
otherwise, the camera image will be blurred and recognition will fail.

8. Fine-tune the Marker Detection Settings if necessary to improve recognition:
· Threshold – defines how visible the lines must be to be recognized. Lower values make lines

easier to detect but may cause false positives; higher values detect only the clearest lines.
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· Min. Line Length – sets the minimum detectable line length. Lines shorter than this are
ignored. Smaller values include shorter lines in recognition.

· Max. Line Gap – defines the maximum allowed gap along a line to still treat it as a single line.
Gaps larger than this are interpreted as two separate lines.

  
9. Start the calibration by pressing the Calibrate button. Three red crosshairs should appear

aligned with your marker points and connected by two green lines (forming an “L” shape). If
so, the calibration is complete.

You can now close the calibration dialog.

 Tips:
· Ensure sufficient lighting and print quality for reliable detection of the markers.
· Poor lighting or low print quality may cause recognition errors.

Measuring the Camera Offset
1. Place a thin piece of material on the machine.
2. Depending on the tool in use (knife or milling cutter), briefly dip into the material to create a

reference mark.
3. Set the relative coordinates to zero.
4. Move the Z-axis to the camera’s operating height.
5. Use X and Y movement to align the crosshair precisely with the mark.
6. The displayed RX and RY values now correspond to the camera offset.

5.14.3 Creating Data for Printing and Cutting/Milling with Corel Draw

When preparing data for printing and cutting/milling, a few important points must be considered.
The following example demonstrates the general procedure. While Corel Draw is used here (as
in the creation of calibration markers), other programs such as Adobe Illustrator can also be
used.

Step 1: Create Layers
1. Start Corel Draw with a blank document.
2. Create three new layers and rename them:
· Print
· Cut
· Marker
3. Set Print as the active layer and import the object to be printed (in this example, a sign that

will be printed on a flatbed printer and then milled along its contour).

If the imported data is on the wrong layer, move it to the Print layer.
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Step 2: Prepare the Cut Path
1. The file already contains a contour (a light outline around the object).
2. Select this line, assign it a distinctive color, and move it to the Cut layer.
3. Create a rectangle that completely encloses the graphic.
4. Assign the rectangle a different, clearly visible line color and place it on the Cut layer as

well.

Step 3: Add Registration Marks
1. Open the file containing the calibration markers.
2. Copy one marker into the current document and duplicate it three times, so that four

markers are available.
3. Use the Align to Objects (Alt+Z) option to position the markers at the corners of the

rectangle so that their centers lie exactly on the rectangle corners.
4. If necessary, move the markers to the Marker layer.

The finished document should now contain:
· The Print layer with the design.
· The Cut layer with the contour and rectangle.
· The Marker layer with the registration marks.

Step 4: Export Files

Two separate files must be exported from the document:
· For printing:
oDisable the Cut layer.
o Export the file as PDF or EPS for printing.

· For cutting/milling:
oDisable the Print and Marker layers.
o Export the file (e.g., via Adobe Illustrator).

 Tip: Adobe Illustrator is advantageous because it preserves different line colors, which are
recognized in cncGraF 8.

Step 5: Workflow in cncGraF 8

· The rectangle surrounding the contour defines the page size but is not cut/milled.
· In cncGraF 8, this rectangle can be deactivated via the tool library.
· After printing, place the printed sheet on the CNC machine bed.
· Start the marker recognition process to align the cutting/milling path with the print.
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5.14.4 Using Video Positioning

Once the camera has been selected and calibration completed, the Video Positioning function
can be used. In the Camera tab, the live video image is displayed along with a toolbar.

Toolbar Options

1. Start
· Activates the Video Positioning function.
· The registration marks are automatically approached and detected.

 For automatic detection, the printed sheet must be positioned at the machine’s origin
point (X=0, Y=0). The drawing must also be loaded at its original- position .

· Start from current position: If the first (bottom-left) registration mark is already visible in the
camera’s field of view, it will be taken as the initial reference mark.

2. Manual Positioning
· When this option is enabled, marks can be positioned manually.
· The machine can be moved either through the Manual Move menu or by clicking directly

on the video image.
· Pressing the Set Position Manually button assigns the current position (the cross in the

camera image) as the marker.
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6 Move

The pull-down main menu “Move” contains all machine-specific functions for controlling the
movement of the CNC machine. This chapter is structured as follows:

· Emulator
· Milling / Drilling
· Manual Move
· Execute Reference Move and Go to Positions
· Check Position
· Probe Workpiece
· Calibrate Tool Length Sensor
· Measure Tool
· Change Tool
· Automatic Workpiece Zero Point Measurement

6.1 Emulator

The Emulator simulates the controller smc5d-m4 and allows the operation of a virtual CNC
machine without requiring any hardware. It can be started via the emulator icon located in the
top-right corner of the main menu.

Once the emulation is running, the orange emulator icon will appear in the status bar at the
bottom of the window.

In addition, the Emulator dialog window opens in the Windows taskbar. Here, inputs can be
defined and then manually toggled using the mouse. For example, this allows the tool length
sensor input switch to be activated virtually via mouse click.
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 To check the execution of individual vectors, you can alternatively use the basic
simulation via the menu: Window → Simulation.
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6.2 Milling / Drilling

The milling process can be started either by clicking the milling/drilling icon  in the horizontal
toolbar or by pressing F9 (Menu: Operation → Milling/Drilling). Before the process begins, the
Job Parameters dialog opens, where the final settings for the machining job can be defined.

There are two variants of the Job Parameters dialog:

· Job Parameters  for 2D files (e.g., HPGL, DXF, …)
· Job Parameters  for G-Code files (DIN66025)

114
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6.2.1 Milling / Drilling 2D Data

2D file formats such as HPGL, DXF, EPS, PostScript do not contain any information required
for CNC machine control. Therefore, essential parameters like processing order, clearance
height, Z-depths, feed rates, etc., must be defined either in the Tool Library  dialog or in the
Job Parameters dialog.

Job Parameters for 2D Files
In the Job Parameters dialog, the following settings can be defined:

Selecting Data and Processing Order
As an example, consider PCB milling. A PCB layout typically consists of an HPGL file and the
corresponding drill file. cncGraF 8 can open, edit, and display both files within a single
document. In the first step, the Job Parameters dialog specifies which dataset should be
processed. You can choose between vectors and drill points (see Figure 2). If the document
contains only drill data (Sieb & Maier) or only vector data (HPGL, DIN 66025), then only the
available data type is shown in the dialog.

Figure 1: If both vectors and drill points are present, a data selection is required.

The tool lists under “Vectors” and “Drill Points” display all tools used in the order in which
they will be processed (from top to bottom) (see Figure 2).
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Figure 2: The option “Tool Change” is active. The processing order can be changed by
selecting a tool and using the arrow buttons.

 Note: For DIN66025 (G-Code) data, the processing order cannot be changed.

Repeat Machining and Step-Down Correction
The values for “Repeat Machining” and “Step-Down Correction in millimeters” are
entered directly by clicking on the corresponding row and column in the tool table.
· A value of 0 means the machining is carried out once.
· A value of 1 means the operation is repeated once.

In combination with Z-axis step-down correction, this function is useful whenever the desired
material removal cannot be achieved in a single pass (e.g., milling grooves in metal, surface
grinding, etc.).
cncGraF 8 offers the following options for Repeat Machining.

1. “Object-based machining” can only be used for 2D data. In this mode, one object is fully
processed before the machine moves on to the next object (see example below).
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Figure 3: Object-based machining

Tool lift – After each object is processed, the tool is lifted.

 Warning: When "Object-related processing" is enabled, 'Continue' (no pause) is not
possible!

2. "Repeat processing without changing the file order" executes the milling process in the
same sequence as the tools are stored in the file. In this case, the tools are taken into account.
Example: In the HPGL file, the following tool sequence is defined: SP1, SP3, SP1, SP2,
SP1. Here, all elements for tool SP1, SP3, and finally SP2 are processed first. After that, the
process is repeated.

Figure 4: "Repeat processing without changing the f ile order" is active. The processing of
the entire file is repeated twice with a depth correction of 1 mm.
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3. "Processing order from file without tool change" executes the milling process exactly as
it is stored in the file. In this case, the tools are ignored. Example: In the HPGL file, the
following tool sequence is defined: SP1, SP3, SP1, SP2. Here, all elements for tool SP1,
SP3, SP1, and finally SP2 are processed.

4. If the above-mentioned options are disabled, the value “Repeat processing” from the tool
list will be executed in the corresponding tool order.

Properties
Under Properties you will find the following functions:

· Tool change: If this option is active, the option Measure tools can also be enabled. After a
tool change, the tool length sensor is approached and the new tool is measured in order to
determine and compensate for the length difference. A simple microswitch (probe) can serve
as the sensor. After the measurement, machining continues with the new tool. To save time, the
tool length can also be taken from the tool library. For this to work, some settings must be
configured. Further information on Tool length f rom the tool library can be found in the
chapter Tool Library  and in the chapter Tool Measurement .

 More details about tool measurement can be found in the chapter Tool Measurement .

· At the end of the milling or drilling process, tasks such as raising the tool, moving to the zero
point, moving to the park position, performing a homing move, or depositing the tool (only for
automatic tool changers) can be carried out automatically.

· After a pause, tasks such as raising the tool, moving to the zero point, or moving to the park
position can be executed automatically. More information about Pause can be found in the
chapter 'Pause' .

· If the surface of the workpiece has been probed beforehand, height compensation can be
activated. More about height compensation can be found in the chapter Workpiece
Probing . 

Clearance Height 
The clearance height F defines the distance between the tool tip and the material during rapid
moves. The distance L is a subsection of the clearance height and is executed at the feed rate of
the Z-axis. If the distance L is set to 0, then the entire descent from clearance height is executed
at rapid speed.

The clearance height can be set automatically using the button . In this case, the current Z-
position of the CNC machine is taken as the new clearance height.

76 131

131

126

127



118 cncGraF 8 Online Hilfe

Copyright © 1993 - 2025 by BOENIGK-electronics

6.2.2 Milling/Drilling from G-Code (DIN66025) Data

Unlike 2D files such as HPGL or DXF, G-Code (DIN66025) files already contain all the
information required for execution on the CNC machine. Therefore, only a few additional settings
are necessary.

Processing Order
The tool sequence is defined in the G-Code (DIN66025) file and cannot be changed. For better
clarity, it is displayed in the Job Parameters dialog (see figure).

Figure: In the following example, tool T2 is used first, followed by tool T1.
Properties
The following functions are available under Properties:

· Tool Change: When this option is enabled, the Measure Tools option can also be activated.
After a tool change, the tool length sensor is triggered to measure the new tool and calculate
the length difference for compensation. A simple microswitch (probe) can serve as the sensor.
Once the measurement is complete, the machining process continues with the new tool. To
save time, tool lengths can also be retrieved from the tool library. For this to work, certain
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settings must be configured. For more details on this, see the chapters Tool Library  and
Tool Measurement .

 For more information on tool measurement, see the chapter Tool Measurement .

· The clearance height is the distance between the tool tip and the material during rapid
traverses.

· At the end of the milling or drilling process, actions such as raising the tool, moving to the zero
point, moving to the park position, performing a reference run, or depositing the tool (only for
an automatic tool changer) can be executed automatically.

· After a pause, actions such as raising the tool, moving to the zero point, or moving to the park
position can also be executed automatically. For more information on pauses, see the chapter
Pause .

· If the surface of the workpiece has been probed beforehand, height correction can be
activated. For more details on height correction, see the chapter  Probing the Workpiece .

 Warning: The functions Height Correction and Add Clearance Height to Output Data
modify the toolpaths of the G-code file.

6.2.3 Speed

With the smc5d controller, the speed of the CNC machine during milling/drilling can be adjusted
in real time by modifying the controller’s clock rate. The adjustment is made using the slider in the
status bar at the bottom of the monitor. If a handwheel is connected, a handwheel icon appears
(see figure).

Figure: Handwheel active – the speed can be adjusted via the handwheel or with the mouse
using the slider.

The following options are available:
· Using the slider or the handwheel dial, you can set the starting speed at which the machining

process begins. If it is unclear whether the file to be processed is error-free, it is recommended
to start with a reduced speed. The speed defined in the file is scaled proportionally (0–100%).
This starting speed applies to milling/drilling operations as well as moves to zero, park, or
measurement points.

· During active machining, the speed can be continuously adjusted from 0 to 100% using the
slider, the handwheel dial, or the +/- keys on the keyboard.
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 In the menu Settings > Options > General → Speed  or via the toolbar icon, you
can configure when the starting speed should automatically reset to 100%.

The available options are:
· Reset at job end or job abort
· Reset when loading a new file
· Reset when restarting the program

6.3 Probe Functions

In the Probe section (menu: Operate > Probe or via the toolbar), various functions for the 3D
probe are available. These functions can be used to determine, for example, edges or midpoints,
with the results applied for zero point determination.

Each function, such as Outside Corner, opens its own dialog window with parameters and an
explanatory graphic. Every dialog window includes, in addition to its title, an option switch and a
round green symbol indicating the input status. In the options, you can define whether the dialog
window should automatically close after measurement and whether the zero point should be
updated. Additionally, an information message can be displayed.

The green input status symbol is used to check the probe’s functionality. When the 3D probe is
triggered, the symbol toggles between on and off.

 In the Positions dialog (menu: Settings > Positions > Measuring Point), multiple
measurements can be enabled. There you can define how many times the measurement should be
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repeated and which maximum deviation is allowed. When this option is enabled, the probing
process is carried out multiple times, the average value is calculated, and the measurement
accuracy is improved.

6.4 Manual Movement

The Manual Movement dialog provides all functions needed to move the machine manually. The
window is docked to the right side of the main window. Using the tack icon, you can define
whether the window should auto-hide or remain permanently visible.

The Manual Movement dialog includes the following functions:
· Manual axis movement
· Setting travel speeds
· Relative movement
· Jogging / Move to position
· Switching pump, spindle, and other outputs
· Executing macros

Manual Axis Movement
The Manual Movement window consists of a vector graphic divided into axes and zones. By
clicking the individual fields, the desired axis and its associated speed are selected. Each field has
its own speed assigned (see figure series).
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Setting Travel Speeds
In the middle of the graphic, there is a circle. By clicking this circle, the Set Speeds dialog opens,
where an individual speed can be defined for each field.
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Relative Movement
The Relative Movement function allows moving a defined relative distance. After entering the
desired distance and clicking the corresponding axis button — which simultaneously determines
the travel direction — the relative move is executed.

Figure: Distance 1 with 100 mm is selected. When clicking X+, the machine moves 100 mm in
the positive X direction.

Jogging / Move-to
The Move-to and Jogging functions are used to approach a specific position. By entering X, Y,
and Z coordinates, the position can be reached either directly or by jogging. If the option Set X/Y
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position with mouse is enabled, the coordinates can be transferred directly into the X and Y
input fields with a left mouse click.

Switching Pump, Spindle, and Other Outputs
Pump and spindle can be switched on or off by clicking the respective buttons. Using the
Customize Layout context menu, additional buttons such as collet or spindle speed can be
added. Furthermore, free buttons can be configured to execute macro commands. This allows
the Manual Movement window to be individually customized. More information can be found in
the chapter Customize Manual Movement .125
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6.4.1 Customize Manual Movement

All dialogs, including the Manual Movement window, can be customized via plug-and-play. To
do this, select the Customize Layout option from the context menu. The context menu opens
when you right-click on a free space in the Manual Movement window between the elements.

After selecting this option, the Layout Customization dialog opens.
At the bottom area, elements are displayed that can be inserted into the Manual Movement
window via drag & drop (select the element, hold down the left mouse button, and move it).
Existing elements can be removed in the same way. In addition, all elements can be moved and
adjusted.

By right-clicking again inside the Manual Movement window, an extended context menu opens
with additional functions for editing and customizing the window.
Several predefined layouts of the Manual Movement window are available. A layout can be
loaded via the Load Layout... button in the lower area of the Layout Customization dialog.

  If something goes wrong during layout editing, the original layout can be restored using
Load Layout....



126 cncGraF 8 Online Hilfe

Copyright © 1993 - 2025 by BOENIGK-electronics

6.5 Performing Homing and Moving to Positions

Various functions are available under the Drive menu to move to specific positions, such as
homing to the zero point or moving to the park position. One of the most important functions is
Homing, which is required for correct machine positioning. After program start, the axis
positions in cncGraF 8 are unknown. Therefore, a homing procedure must first be performed.
For safety reasons, this typically begins with the Z-axis moving upward, followed by the X, Y,
and other axes.

In the Homing dialog, you can select which axes should be referenced. If the check mark for an
axis is removed, that axis will be excluded from the homing process. For CNC machines without
reference switches, or during initial setup, the reference point can also be defined manually via
View > Set Ref erence Point.... Once homing is completed, the absolute coordinates in the
program’s main menu are reset to their initial values.
 
By default, homing is executed at reduced speed, which can take considerable time on large
CNC machines. The Fast Homing function therefore first performs a rapid move to a
predefined position near the reference point (X, Y, and Z) (see chapter Machine Setup  > Axes
> Homing). The actual homing process then starts from this point.

 The Fast Homing function cannot be used immediately after program start. It is only
available if:
· the CNC machine’s position is already known, and
· all axes have already been referenced.

To move to a zero point, park position, or measurement position, it must first be defined in the
Edit Positions dialog (menu: Settings > Positions or via the toolbar icon).

During homing, the travel direction is indicated by arrows, which serve as a control for the
settings:
<-- = move toward the reference switch
-> = move away from the switch

6.6 Pause and Abort

While the CNC machine is running, all functions are disabled—except for Pause and Abort.
Both functions stop the machining process but differ in their behavior:

· Pause: The machine is stopped using a deceleration ramp. Machining can then be resumed
without requiring a new homing procedure.

· Abort (ESC key): The machine is stopped immediately without a deceleration ramp. This may
cause step losses, which makes it mandatory to perform a homing procedure afterward to
reestablish the correct position. ist.
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6.7 Check Position

The Check Position function (Menu: Run > Check Position) performs a homing cycle. In
contrast to a normal homing cycle, the current position is verified, and at the end, the step losses
of each axis are displayed.

 Important: After configuring all machine parameters, this function must be executed to
verify both the settings and the hardware.

For detailed instructions on performing a position check, see the chapter Step Losses .

If a CNC machine shows step losses, several factors may be responsible. Common causes
include:

·  Excessive speeds → verify in the dialog Machine Parameters > Check Speeds.
· Incorrect motor power supply (too little or too much current) → check hardware settings

(motor drivers).
· Improper motor current reduction → verify in Machine Parameters > Pin Assignment.
· Incorrect step signal direction → adjust the step signal for the stepper motors in Machine

Parameters > Pin Assignment > Invert Step  Signal.
· Hardware issues → axes move sluggishly, jerk, or get stuck.

6.8 Probe Workpiece

The Probe Workpiece function (Menu: Run → Probe → Probe Workpiece) enables milling
on uneven surfaces. Before the machining process begins, the surface is scanned in the Z-
direction using a predefined grid. The collected data is then used to correct the Z-axis so that the
milling tool maintains a constant cutting depth – within the specified tolerance – during machining.

Functions of the Probe Device dialog

Edge Clearance
Prevents errors when probing near the edges of the workpiece by ensuring the probing area does
not reach the very edge.

Probing Area
Defines the size of the probing area in the X and Y directions (in millimeters).

Abort on Tolerance
Safety function: Compares the current measurement with the previously recorded value. If the
difference exceeds the set tolerance, the machine stops immediately.

46
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 Warning: The Abort on Tolerance safety function should always be enabled.

Grid Division
The probing grid in the X and Y directions is determined by dividing the length and width of the
probing field.
Example: With a side length of 100 mm and a division of 5, a total of six probing points are
created, each spaced 20 mm apart. For relatively flat surfaces, only a few grid points are
sufficient to achieve the desired precision of height correction.
For verification, the probing area can be displayed by enabling Show Probing Area or by
selecting Main Menu > View > Probing Area after the probing process.

 The dimensions of the final engraving or milling pattern must always be smaller than the
defined probing area.

Lift Probe
Defines the clearance distance of the tool tip above the material during rapid traverses.

Probe Deviation
At the end of the probing process, the program calculates ideal values for each grid field
(rectangle) based on the measured data. The deviation is the difference between the ideal value
and the measured value. The largest deviation is always displayed.
If the deviation exceeds 0.1 mm, the grid field may contain a bump or dent. In such cases, a finer
grid should be chosen and the surface re-probed.

 The deviation can also be displayed later via Main Menu > View > Probe Deviation...

Export / Import Probing Data
The probing results can be exported or imported (Menu: File → Probing Data). Data can be
saved as DXF (lines or points), DIN66025, text files, or as a cncGraF 8 SCAN file. SCAN files
can later be re-imported into cncGraF 8 using the import function.

6.9 Calibrate Tool Length Sensor

In order to measure tool length, a one-time calibration of the tool length sensor is required. This
is carried out using a wizard. Before starting the wizard, a measuring point must be defined under
Settings > Positions > Measuring Point. Instructions and notes for this can be found in the
chapter Measuring Points .

 Important: The correct input for the tool length sensor must be selected in the machine
parameters and should be verified. To do this, press the tool length sensor input and check in the

73
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status bar (via the USB/Ethernet symbol). The input must change, and the input number must
match the setting under Machine Parameters > Pin Assignment > Measure Tool Length.

The tool length sensor calibration wizard guides you step by step through the following tasks:

1. Reference Run
For accurate position detection, a reference run must first be executed. If it has already been
carried out, this step can be skipped by selecting Next.

2. Measure Machine Table Height
·  Mount any tool.
· Lower the Z-axis until the tool tip touches the machine table.
· Save the table height by selecting Click here to save the table height in the dialog.

From the saved table height and the material thickness, the zero point height (Z0) is calculated.
The material thickness starts at the height of the machine table and ends at the top surface of the
material (see figure).

Figure: Table height and material thickness together define the zero point height.

 In the Positions  dialog, the zero point height can be defined by entering the material
thickness.

70
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3. Summary
On the final page of the wizard, the table height and the switching height of the tool length sensor
are displayed. Clicking Finish saves the values and closes the wizard.

4. Measure Tool Length Sensor
The tool length sensor is approached to determine the switching height.

 If the tool length sensor is no longer used, the calibration can be disabled (Run > Tool
Length Sensor > Enable/Disable Calibration).

5. Tool Length Sensor – Properties
The determined values Table Height and Switching Height can be manually adjusted in the
Tool Length Sensor Properties dialog. This dialog can be accessed via Run > Tool Length
Sensor > Tool Length Sensor Properties in the main menu.

 Caution: Editing these values should only be done in exceptional cases and requires in-
depth system knowledge.
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6.10 Measure Tool

To measure the tool length (Menu: Run → Tool → Measure Tool), a tool length sensor is
required. This sensor must first be set up through a one-time calibration.

 For more information on measuring points, refer to the chapter Positions > Measuring
Points .73
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6.11 Tool Change

The Tool Change function (Menu: Run → Tool → Tool Change ) can only be used if an
automatic tool changer and a park position  are available. Two types of tool changes are
supported:

Manual Tool Change
The change is performed manually by the machine operator at the defined park position.

Automatic Tool Change
The change is carried out by the automatic tool changer. If the selected tool number exceeds the
number of available slots in the tool changer, the change must be performed manually at the
defined park position.

 To execute the tool change, the option Tool Change must be activated in the Job
Parameters dialog (F9).

40
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6.12 Automatic Measurement of the Zero Point with Probe Block

cncGraF 8 can automatically measure the Z-height of the zero point. This requires a probe block
or a 3D probe. With a 3D probe, the zero point for the X and Y axes can also be automatically
determined. For more details on the 3D probe, see the chapter Probes .

Requirements for Probe Block
· In the menu Settings > Machine Parameters > Pin Assignment, the input for automatic

measurement must be defined.
· The assigned pin can be identified via View > Interface. Press the sensor – the input will

change its status, confirming the correct pin.
· The measurement speed for the Z-axis must be set very low (Machine Parameters > Speeds >

Measurement Speed for Zero Point X, Y, and Z).
· The exact probe block height in millimeters must be specified (see figure).

120
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7 Edit

cncGraF 8 can process two types of data:

2D files (e.g., DXF)
These files do not contain machine-specific parameters such as feed rates, tool definitions,
machining sequences, or tool compensation. For milling, this information must be added within
the program. This approach is particularly suitable for beginners, as it allows simple 2.5D tasks,
such as milling or drilling front panels, to be implemented quickly.

G-code files (DIN66025)
These files are complete machine files and contain all the required information for CNC
operation. Handling them is more complex but provides full functionality and flexibility.

Since G-code files (DIN66025) are already fully prepared for the milling process, they are not
edited. The functions described in this chapter apply exclusively to the editing of 2D files (e.g.,
DXF).

 The editing functions for 2D files can be found in the Tool Palette window (Menu:
Window > Tool Palette).

 The Tool Palette can be customized in the menu Settings > Options > General & Tool
Palette by hiding functions that are not required.

Edit Drawing
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The Edit Drawing section provides basic functions for positioning, rotating, or mirroring a
drawing on the machine surface or a defined workpiece.
Additionally, it is possible to stretch a drawing (mainly useful for testing the CNC machine) or
round corners.

The most important function in this area is positioning on the workpiece, as this is usually the
first step after opening a drawing.

Tools
The Tools section contains functions for tool operations:

Automatic tool compensation (radius compensation) can be applied to the entire file.
To apply tool compensation to polylines, select the desired polyline with the mouse using the
selection rectangle (see Figure) and then calculate the radius compensation with the Set
button. More information about the selection rectangle can be found in the respective chapter.

A pocket with an island is created by first calculating the pocket. Then, the inner polyline is
selected with the mouse and confirmed with the Clear button (see Figures).
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The tool palette also provides the Tool Properties function. This allows the tool number and/or
milling direction to be adjusted for a selected element (polyline).

Convert points into drill points:
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cncGraF 8 supports importing Sieb & Maier files. Since this format is only used by a few
programs (mainly PCB layout software), cncGraF 8 provides a tool to generate drilling data
directly from 2D files. For this, drill points in the 2D file (HPGL or DXF) must be drawn as

points or – recommended – as crosses .

Simple tabs can be set by clicking the desired vector.

Lead-in and lead-out can be added as a line or arc. In this case, the machine approaches the
contour laterally in the X and Y directions (no plunge in Z).

Machining Sequence

This section defines the processing order within a tool. Polylines can be moved to the beginning
or end of the machining sequence or assigned a starting point.

 Important: The Path Optimization function can correct errors in DXF files – such as
duplicate vectors or open polylines – and optimize toolpaths.
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7.1 Selection Rectangle

The Selection Rectangle function allows you to edit parts of a drawing (move, rotate, copy, or

delete) using the mouse. First, you need to select the data type via the symbol  in
the horizontal toolbar (options: vectors, polylines, radius-compensated polylines, drill points, or
all).

Afterwards, a cross-shaped mouse pointer appears on the graphical surface. By holding down
the left mouse button, you can draw a rectangle that encloses the elements to be edited. Once
released, the selection rectangle appears with the chosen drawing elements highlighted (see
Figure).

Figure: Content of the selection rectangle can be rotated, copied, or moved.

After making a selection with the mouse, you can now perform the desired action by choosing
the corresponding function key and clicking the left mouse button on the workspace.

Descrip tion Key Menu Command

Delete [Del]
Edit > Selection Rectangle

Content > Delete
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Descrip tion Key Menu Command

Copy
[Ctrl + C] and left

mouse button
Edit > Selection Rectangle

Content > Copy

Move
[Ctrl + X] and left

mouse button
Edit > Selection Rectangle

Content > Move

Rotate
Selection rectangle

center   + left
mouse button

none

Change milling
direction and tool

number

Right mouse button
> Properties...

none

7.2 Drag Knife Compensation

 The drag knife compensation can only be applied to HPGL files.

Before a cutting operation, the orientation of the swivel knife is unknown. Therefore, it must first
be aligned in the Y-direction (Figure 1).
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Figure 1: Starting position of the swivel knife

Immediately after the start, the knife is precisely aligned using an alignment cut in the Y-direction
(Figure 2).

Figure 2: Alignment cut

Drag Knife Compensation
In the dialog window Drag Knif e Compensation, the swivel knife radius is corrected. This
window can be opened via the main menu: Edit > Drag Knife Compensation…
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Drag Knife Parameters
· Knife Offset: This is the distance between the knife’s pivot axis and the knife tip (knife

radius).
· Start Angle: The start angle defines the angular difference at which the compensation path for

the drag knife is calculated. The larger the start angle, the rounder the cut corners will be. A
value of 8 degrees is recommended.

· Scaling: With scaling, the drawing can be enlarged as desired. After the calculations have
been performed, the drawing must not be scaled any further, since this would also change the
knife radius.

Drag Knife Alignment
· Offset Distance: Defines the distance of the alignment cut from the actual contour.
· Length: Specifies the length of the alignment path.
· Align: If this option is checked, the machine will perform the alignment cut.usrichtungsstrecke.

The Of f set Distance value should be chosen so that the alignment cut lies outside of the
contours, otherwise the actual contour could be damaged!

Once all parameters have been set, you can confirm them with OK, and cncGraF 8 will calculate
the cutting paths.

 When aligning the Z-zero point, be sure to consider the cutting depth of the foil (or
cardboard).

7.3 Nesting

The Nesting function (Window: Tool Palette > Extras) arranges 2D elements in a space-
saving way on a workpiece. Multiple files can also be added simultaneously for nesting.

7.4 TeachIn

TeachIn (Window: Tool Palette > Extras) is a tool used to move the machine to specific
positions and then save these positions in an HPGL file or a G-Code file (DIN66025).

After opening the TeachIn function, the desired positions can be reached using Manual Move
and added to the output list via Add.
Once all points are entered, the output list can be saved as an HPGL or G-Code file.

121
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8 TCP Server/Client and Modbus TCP Client
Communication

To send or receive data via TCP or Modbus TCP, data channels must (Menü: Extras ->
Admin of  data channels) first be defined. These channels are divided into receive channels and
send channels. An example of a send channel is “Send CNC machine X position”, which
transmits the current X position. A receive channel could be “Execute ‘Start Job’ once the
value in column ‘P’ is received.”

 Note: For send channels, it is recommended to use the transmission type “On value
change” to avoid unnecessary traffic caused by multiple transmissions.

Configuration of TCP and Modbus Clients/Servers
In the corresponding dialog window, TCP servers or TCP/Modbus clients can be created.
Filters allow you to link previously defined data channels with the connections.

 Important: The transaction ID is unique for each request (usually incremented
sequentially). It assigns incoming responses to the correct data channels and is therefore
particularly necessary when receiving commands.

TCP/IP Server/Client
· Packets (strings) of variable length are transmitted.
· The end of a packet is marked by a delimiter (e.g., <EOF> or \r\n). The delimiter can be

chosen freely.
· Identifiers can be added at the beginning or end of a packet, e.g., X= for the X position.
· Example: X=147,141<EOF>

Modbus TCP (Client only)
· Modbus packets such as Holding Registers or Coils are used.
· Each packet contains a transaction ID (ushort), which is required for uniquely assigning the

response.

9 Integrated Text Editor

The internal text editor is a fully functional editor that can load G-Code (DIN66025) and HPGL
files, offering the following features:

· Syntax highlighting for G-Code (DIN66025), with commands marked in blue.

· In the text editor, DIN66025 files can be extended with additional commands using
autocomplete. Press CTRL + Space to open the autocomplete menu (see Figure 1).
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Figure 1: Autocomplete was triggered in line 8 using CTRL + Space, and subroutine P1 (this
is my f irst subroutine!) was selected.

· In the text editor’s main menu (Edit -> Subroutines), subroutines can be managed.
Subroutines can be inserted into DIN66025 files with the help of autocomplete.

Figure 2: A pause was set at line 7

· In the text editor’s main menu (Edit -> Subroutines), subroutines can be managed.
Subroutines can be inserted into DIN66025 files with the help of autocomplete.
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Figure 3: The description of the subroutine appears as a tooltip in the autocomplete menu
 

· The text editor also provides Find & Replace, Go to..., and a Print function with print
preview (Menu: Search and File -> Print).

· In the 3D view, DIN66025 files can be checked. The selected line in the text editor is
highlighted in the 3D view with a yellow cylinder.

 The text editor is a dockable window and can be positioned on any side of the main
window.
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10 3D View

The 3D View function makes it possible to generate a 3D model and display G-code lines in the
3D window. The function is accessed via Window > 3D View. Additionally, a 3D toolbar is
available, which can be displayed in the menu by right-clicking.

 The 3D View requires a powerful graphics card with OpenGL support!

3D Model
In the 3D View, a 3D model can be generated. The following conditions must be met:
· Suitable tools (tool type, diameter) must be defined in the tool library for the loaded data.
· A workpiece must be defined for the 3D model generation. In the Workpiece Parameters

dialog, a sufficiently large workpiece in X, Y, and Z must be specified.
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DIN66025 Commands
DIN66025 commands can be verified in the 3D View. In the text editor , the currently
selected line is highlighted in the 3D window (yellow cylinder). By pressing CTRL + left mouse
button, a vector can be selected directly in the 3D View.

11 System Settings

All settings, except for the tool library, are stored in the configuration file config.xml. The
configuration file is an XML file and can be opened in any text editor. In the main menu, the
configuration file can be loaded via Settings → Settings → Load....

The config.xml file is located in the directory: ...\Users\[BENUTZERNAME]
\AppData\Roaming\cncGraF8\.

The configuration file contains several parameters that are not available through dialogs. To
change these parameters, open a previously saved config.xml file in a text editor.

 Save your cncGraF 8 settings by selecting Settings → System Settings → Save. Keep
the generated system file in a secure location (not on the same PC, but for example on a USB
stick or CD-ROM).
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12 Fehlerbehebung

Error Possible Solution

Error: No connection to the control
electronics smc5d

- Disconnect and reconnect the USB cable.
- Try using a different USB cable.
- Increase the parameter Interrupt af ter in the menu
Machine Parameters → Connection.
- Switch the entire electronics off and on again.
- Exit the program and restart it.
- Check the Windows Device Manager to verify
whether the control electronics smc5d are correctly
recognized by the Windows operating system. In the
USB Controllers section, smc5d must be listed.

During the homing process, at least
one axis moves slowly away from or
onto the switch

The homing direction is set incorrectly and must be 
changed. For correct adjustment of the homing

switches, 
use the Homing Switch Assistant. For more details,

see the 
chapter Homing Switches .

Machine makes noise but does not
move

The stepper motors are receiving insufficient current.
The motor current must be inverted. For further details,
see the chapters Pulse Settings for the Drivers  and
Motor Check .

Machine runs fine at first, but after a
few minutes the connection drops or
error messages occur

The PC may be shutting down after a few minutes.
Disable the power management in the BIOS. Also
check the power options in the Windows Control
Panel.

 Important: To prevent the PC from causing interruptions, power management in the BIOS
must be completely disabled. Also review the power options in the Windows Control Panel.
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